【问题标题】:webdav query Unauthorized on production server and authorized on testing serverwebdav 查询在生产服务器上未授权,在测试服务器上授权
【发布时间】:2009-11-30 09:37:37
【问题描述】:

我正在尝试使用 webdav 访问我的交换收件箱,它可以在我的测试服务器(windows 2003 64 位,包含 MOSS 安装)而不是我的生产服务器(windows xp 32 位)上运行。

用于身份验证使用:

ICredentials credentials = CredentialCache.DefaultCredentials;  

我从我的生产服务器得到:

The remote server returned an error: (401) Unauthorized.    

我的生产服务器上可能有什么问题,它是如何在我的测试服务器上工作的?

【问题讨论】:

    标签: c# sharepoint exchange-server webdav


    【解决方案1】:

    也许是因为在测试机器上您也是管理员。尝试将凭据显式设置为已知具有所需访问权限的用户帐户。 DefaultCredentials 可能会恢复为本地计算机或网络服务帐户(尽管不确定)。

    【讨论】:

    • 你是对的,我也是测试服务器上的管理员。我如何发送当前登录用户的凭据?
    【解决方案2】:

    检查本地环回检查

    http://support.microsoft.com/kb/896861

    【讨论】:

      猜你喜欢
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 2021-07-09
      • 1970-01-01
      • 2012-04-29
      • 1970-01-01
      • 2018-05-09
      • 2015-03-31
      相关资源
      最近更新 更多