【问题标题】:Restore MySQL database from a broken hard disk从损坏的硬盘恢复 MySQL 数据库
【发布时间】:2017-06-09 10:33:25
【问题描述】:

几天前我的硬盘坏了,所以我不得不用新的硬盘更换我的电脑,我根本无法进入操作系统,因此我无法备份我的 MySQL 数据库,但是我设法从损坏的硬盘中保存了整个 xampp 文件夹。

但是,当我使用新安装的 xampp 将 mysql 文件夹中的数据库文件夹复制并粘贴到新硬盘时,我无法打开我的表,它显示错误“#1932 - 引擎中不存在表”,所以我尝试复制mysql中的整个数据文件夹,MySQL服务无法启动。

我还尝试将 ib_logfile0、ib_logfile1 和 ibdata1 复制到新驱动器中,然后我什至无法登录到 phpmyadmin,并说“配置中定义的 controluser 连接失败。”无法通过cmd连接mysql出现“1006未知错误”。

现在如何从旧驱动器中抢救我的数据库?

非常欢迎所有建议。谢谢。

【问题讨论】:

标签: php mysql database


【解决方案1】:

您是否可以只从旧文件夹运行 xampp(没有新安装的 xampp)?我在一个论坛上读到,如果您安装了 xampp 的非 zip 版本,这是可能的。如果您在使用新版本 xampp 上的旧文件夹时遇到问题,我会尝试运行复制的 xampp 看看会发生什么...

【讨论】:

    猜你喜欢
    • 2011-09-25
    • 2012-05-27
    • 2021-09-10
    • 1970-01-01
    • 1970-01-01
    • 2013-12-07
    • 1970-01-01
    • 2011-01-12
    • 2013-08-18
    相关资源
    最近更新 更多