【问题标题】:Opcache is Enabled, but Opcode Caching says Disabled?Opcache 已启用,但 Opcode Caching 显示已禁用?
【发布时间】:2015-12-04 13:49:11
【问题描述】:

我附上了截图。关于我所缺少的任何想法?我已通过php.ini 启用它,它在phpinfo 中显示为enabled,但显示为opcode caching is disabled。使用 PHP 5.5。

【问题讨论】:

  • 您是否检查过该屏幕截图中标识的 opcache 错误日志?答案可能就在那里。
  • 我有,可惜是空的。
  • 这是在 Windows 平台上吗?来自php.net/manual/en/opcache.configuration.php:“在 Windows 上运行 PHP 时,您需要以本地管理员身份运行 Web 服务(Apache 或 IIS),以允许 PHP 创建共享内存段。如果您以其他方式运行 Web 服务,OPCache将被禁用。”
  • 它在 Ubuntu 14.04 上。
  • 你重启过网络服务器吗?

标签: php opcode-cache


【解决方案1】:

我自己找到了这个问题的答案,但我希望其他人也知道他们是否遇到了这个问题。

无论出于何种原因,在服务器上为 opcache 生成了多个 .ini 文件,它们包含相同的设置。

我删除了一个,重新启用了 opcache,现在它可以正常工作了。

【讨论】:

    猜你喜欢
    • 2019-03-20
    • 1970-01-01
    • 2018-08-30
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 2017-08-02
    • 2011-06-19
    • 1970-01-01
    相关资源
    最近更新 更多