【问题标题】:blogdown::serve_site() times out and live preview in viewer does not loadblogdown::serve_site() 超时并且查看器中的实时预览不加载
【发布时间】:2020-10-30 02:06:04
【问题描述】:

我使用 blogdown 创建了一个站点,但一直没有部署它。我可能有一个半月没有碰过我的网站,但当时实时预览正在运行。我可以在查看器标签中看到我的网站的预览。

今天,我打开了我的项目,并且 blogdown 在启动时启动了实时预览。但是,我收到以下错误:

ERROR: The process "2848" not found.
Error: It took more than 30 seconds to launch the server. There may be something wrong. The process has been killed. If the site needs more time to be built and launched, set options(blogdown.server.timeout) to a larger value.

我重新启动了 R 和我的设备。我更新了 R、Rstudio 和我所有的软件包。我仍然收到错误但每次打开项目或运行blogdown::serve_site().时进程号都会更改@

我想我的网站可能加载时间过长,因为它太大了,尽管到目前为止它只有几篇文章。因此,我尝试使用默认的 Hugo 主题创建一个新的测试站点,它在预览时按预期启动。但是,如果我尝试使用 install_theme() 更改 Hugo 主题,我会遇到同样的错误消息。

> sessionInfo()
R version 4.0.3 (2020-10-10)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows 10 x64 (build 19041)

Matrix products: default

locale:
[1] LC_COLLATE=English_United States.1252 
[2] LC_CTYPE=English_United States.1252   
[3] LC_MONETARY=English_United States.1252
[4] LC_NUMERIC=C                          
[5] LC_TIME=English_United States.1252    

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

loaded via a namespace (and not attached):
 [1] Rcpp_1.0.5      bookdown_0.21   ps_1.4.0        digest_0.6.27  
 [5] later_1.1.0.1   R6_2.5.0        jsonlite_1.7.1  magrittr_1.5   
 [9] evaluate_0.14   blogdown_0.21   rlang_0.4.8     promises_1.1.1 
[13] rstudioapi_0.11 rmarkdown_2.5   tools_4.0.3     servr_0.20     
[17] processx_3.4.4  httpuv_1.5.4    xfun_0.18       yaml_2.2.1     
[21] compiler_4.0.3  htmltools_0.5.0 knitr_1.30

10/30 更新:问题已解决

按照 cmets 中的建议,我运行了 blogdown::build_site,这给了我不同的错误。我修复了第一个关于错误请求的问题。我现在无法重现该错误,但修复方法是将 ignoreErrors =["error-remote-getjson"] 添加到我的 config.toml 文件中

【问题讨论】:

标签: r blogdown


【解决方案1】:

由于您没有提供可重现的示例,我目前的猜测是您遇到了I have fixed two weeks ago 的 blogdown 错误。请尝试当前的开发版本:

remotes::install_github('rstudio/blogdown')

记得重启R。

【讨论】:

  • 我试过这个,但我得到了一个类似的错误,关于服务器花费超过 5 秒。不确定如何提供可重现的示例,因为它发生在启动时。以下是我采取的步骤: 1. 打开 R 2. 打开项目 3. blogdown:::preview_site(startup = TRUE 自动在控制台中运行
  • 在哪里设置 blogdown 选项?该错误建议将 options(blogdown.server.timeout) 更改为更大的值。
  • 您可以在文件.Rprofile中设置选项。但是,我怀疑它是否会有所帮助。尝试运行blogdown::build_site(),看看它是否能告诉你更多信息。
  • 谢谢!我运行了blogdown::build_site(),它给了我一个错误的请求错误,我能够修复它。
  • @YihuiXie 我面临与上述完全相同的问题。我尝试了您上面建议的步骤。当我运行 blogdown::build_site() 时,它顺利进行,没有任何问题。不过,我无法预览我的网站。
猜你喜欢
  • 2021-11-09
  • 1970-01-01
  • 2023-04-07
  • 2020-11-14
  • 1970-01-01
  • 1970-01-01
  • 2021-01-12
  • 1970-01-01
  • 2021-02-09
相关资源
最近更新 更多