【发布时间】:2015-03-30 14:14:30
【问题描述】:
我正在使用 Cloudera Quickstart VM 5.3.0(在 Windows 7 上的 Virtual Box 4.3 中运行)并且我想学习 Spark(在 YARN 上)。
我启动了 Cloudera Manager。在侧边栏中,我可以看到所有服务,有 Spark,但处于独立模式。所以我点击“添加新服务”,选择“Spark”。然后我必须为这个服务选择依赖集,我没有选择我必须选择 HDFS/YARN/zookeeper。 下一步我必须选择一个历史服务器和一个网关,我在本地模式下运行 VM,所以我只能选择 localhost。
我点击“继续”并出现此错误(+ 69 条痕迹):
发生服务器错误。将以下信息发送至 Cloudera。
路径:http://localhost:7180/cmf/clusters/1/add-service/reviewConfig
版本:Cloudera Express 5.3.0(由 jenkins 构建的#155 20141216-1458 git: e9aae1d1d1ce2982d812b22bd1c29ff7af355226)
org.springframework.web.bind.MissingServletRequestParameterException: 必需 长参数“serviceId”不存在于 AnnotationMethodHandlerAdapter.java 中的第 738 行 org.springframework.web.servlet.mvc.annotation.AnnotationMethodHandlerAdapter$ServletHandlerMethodInvoker raiseMissingParameterException()
我不知道是否需要互联网连接,但我确切地说我无法使用虚拟机连接到互联网。 (编辑:即使有互联网连接,我也会遇到同样的错误)
我不知道如何添加此服务,我尝试过使用或不使用网关,有很多网络选项,但它从未奏效。我检查了已知问题;没什么……
有人知道我可以如何解决此错误或如何解决吗?感谢您的帮助。
【问题讨论】:
-
我希望我这样做了......不幸的是,这不是因为双击。
标签: apache-spark cloudera cloudera-manager cloudera-quickstart-vm