【发布时间】:2019-11-17 18:49:01
【问题描述】:
我正在使用 redis alpine 容器,我只是在生产中遇到此错误 - 在我的服务器上。 我找到了MISCONF Redis is configured to save RDB snapshots 并通过了它,但那里的建议都不起作用。
这是错误信息:
$ node dist/queue.js
events.js:174
throw er; // Unhandled 'error' event
^
ReplyError: MISCONF Redis is configured to save RDB snapshots, but it is currently not able to persist on disk. Commands that may modify the data set are disabled, because this instance is configured to report errors during writes if RDB snapshotting fails (stop-writes-on-bgsave-error option). Please check the Redis logs for details about the RDB error.
at parseError (/home/deploy/gympoint/node_modules/redis-parser/lib/parser.js:193:12)
at parseType (/home/deploy/gympoint/node_modules/redis-parser/lib/parser.js:303:14)
Emitted 'error' event at:
at /home/deploy/gympoint/node_modules/beequeue/lib/queue.js:322:14
at /home/deploy/gympoint/node_modules/beequeue/lib/queue.js:177:21
at Object.callbackOrEmit [as callback_or_emit] (/home/deploy/gympoint/node_modules/redis/lib/utils.js:89:9)
at RedisClient.return_error (/home/deploy/gympoint/node_modules/redis/index.js:706:11)
at JavascriptRedisParser.returnError (/home/deploy/gympoint/node_modules/redis/index.js:196:18)
at JavascriptRedisParser.execute (/home/deploy/gympoint/node_modules/redis-parser/lib/parser.js:572:12)
at Socket.<anonymous> (/home/deploy/gympoint/node_modules/redis/index.js:274:27)
at Socket.emit (events.js:198:13)
at addChunk (_stream_readable.js:287:12)
at readableAddChunk (_stream_readable.js:268:11)
error Command failed with exit code 1.
info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.
【问题讨论】:
标签: node.js docker deployment redis