【问题标题】:Unable to connect PostgreSQL(pgAdmin 4) to the Google Cloud Platform无法将 PostgreSQL(pgAdmin 4) 连接到 Google Cloud Platform
【发布时间】:2021-09-20 09:23:05
【问题描述】:

我在 Google Cloud Platform 上有实例,我正在尝试将其连接到 pgAdmin 4。

这是我的 postgresql.conf

所以我尝试了以下方法:

我已经写好了实例ip以及用户名和密码。

我收到以下错误:

我已经在云实例上添加了我的 IP 地址,但这也没有帮助。

还有什么我可以尝试的吗?

【问题讨论】:

  • 所有需要做的事情都已正确完成,很难说出是什么原因造成的。我建议您首先按照documentation 中的说明尝试通过命令行进行连接,以检查其中的结果。让我知道你之后是否能够连接。
  • 'timeout expired` 在这种情况下通常意味着防火墙阻止了连接。 5432端口是否开放给外部访问?
  • @AdrianKlaver 非常感谢,我的端口没有打开。所以我手动打开它,如果有人需要有关如何打开端口here 的链接。
  • 请记住,您现在已将数据库开放给公共访问,这取决于您允许进入的 IP。确保您的 pg_hba.conf 和角色安全性足以应对此问题。
  • @AdrianKlaver 你有任何链接,所以我可以看看如何配置它或?

标签: postgresql google-cloud-platform cloud pgadmin-4


【解决方案1】:

将其发布为社区 wiki,因为这是基于 @AdrianKlaver 共享的 cmets:

鉴于您收到timeout expired 错误,这通常意味着防火墙阻止了连接,这很可能是端口 5432 未对外部访问开放的问题,因此如果您更改它可能会起作用。

注意:请记住,一旦执行此操作,您将根据您允许的 IP 将数据库打开到公共访问。确保您的 pg_hba.conf 和角色安全性足以处理它。您可以通过关注Client Auth 和Create Roles 的这两个文档链接来找到有关如何设置的更多信息

【讨论】:

    猜你喜欢
    • 2021-09-17
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 2021-10-21
    • 1970-01-01
    • 1970-01-01
    相关资源
    最近更新 更多