【问题标题】:While unloading the table to s3 the database gets restarted将表卸载到 s3 时,数据库会重新启动
【发布时间】:2017-02-21 08:24:21
【问题描述】:

我正在尝试将表卸载到 S3,每当我尝试时,我都会收到以下消息。

致命:发生致命错误。数据库将重新启动。 SSL SYSCALL 错误:检测到 EOF 与服务器的连接已丢失。尝试重置:失败。

query= UNLOAD (' select * from public.table ') to 's3://bucket/path/in/s3/' credentials 'aws_access_key_id=####;aws_secret_access_key=####' delimiter '\ t' GZIP PARALLEL ON ALLOWOVERWRITE NULL AS 'M15sInGValue57ring' ESCAPE ADDQUOTES;

【问题讨论】:

    标签: amazon-redshift


    【解决方案1】:

    NULL AS 字符串不能超过 18 个字符。

    UNLOAD (' select * from public.table ') 到 's3://bucket/path/in/s3/' 凭据 'aws_access_key_id=####;aws_secret_access_key=####' 分隔符 '\t' GZIP PARALLEL ON ALLOWOVERWRITE NULL AS 'M15sInG57ring' ESCAPE ADDQUOTES;

    有效!!!

    失败的原因?

    • 卸载时遇到空值时,将替换为空值 AS 字符串。
    • 它希望它少于 18 个字符。 否则在转换时会失败。
    • 以便数据库重新启动。

    【讨论】:

      猜你喜欢
      • 1970-01-01
      • 2017-07-31
      • 2021-08-15
      • 1970-01-01
      • 2020-02-11
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      相关资源
      最近更新 更多