【问题标题】:SQL Server 2008 Express failed to attach mdf fileSQL Server 2008 Express 无法附加 mdf 文件
【发布时间】:2009-09-15 02:15:56
【问题描述】:

这是消息。它出什么问题了?是安装问题吗?

标题:Microsoft SQL Server Management Studio

无法显示请求的对话框。


附加信息:

参数名称:nColIndex 实际值为-1。 (Microsoft.SqlServer.GridControl)


按钮:

好的

【问题讨论】:

标签: sql-server


【解决方案1】:

您是否尝试使用 SQL 身份验证或 Windows 身份验证附加 mdf?如果使用 SQL 身份验证,您可以尝试使用 Windows 身份验证。

您可能还想查看此MSDN forum postthis post,它建议使用数据库附加的单文件版本:

USE master;
GO
EXEC sp_attach_single_file_db @dbname = 'AdventureWorks',  @physname = N'f:\dataAdventureWorks_Data.mdf';

编辑: 运行此脚本时,您必须以至少具有 dbcreator 权限的用户身份登录。您也可以尝试 CREATE DATABASE FOR ATTACH,如this blog post 所示

【讨论】:

  • 我正在使用 Windows 身份验证。是的,我以前看过这个帖子。这并不能解决问题......
  • 上面的脚本给了我一个错误信息:数据库'master'中的CREATE DATABASE权限被拒绝。
【解决方案2】:

我更喜欢 Windows 身份验证,并且在使用 SQL Server 标准版时遇到了同样的错误,因为我的 Windows 身份验证登录没有足够的权限(只是“公共”角色)。所以登录为“sa”并为我的 Windows 帐户登录添加“sysadmin”角色解决了这个问题。

【讨论】:

  • 谢谢,MicMit,非常感谢!
【解决方案3】:

有同样的问题。 似乎出现错误是因为我已连接到 SQL SERVER 2012 INSTANCE 使用 Sql Server 2008 R2 管理工作室。 希望对其他人也有帮助

【讨论】:

    猜你喜欢
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 2010-12-21
    相关资源
    最近更新 更多