【发布时间】:2019-10-31 10:56:48
【问题描述】:
我是 Nginx 和 EC2 的新手,并尝试添加一些简单的身份验证,如下所示。这是一个单页应用程序,我想保护对页面的访问,但不保护磁贴服务器。没有身份验证一切正常。使用下面的身份验证,我会收到一条错误消息;
http://map.domain.org.uk is requesting your username and password. The site says: “GeoServer Realm”
我认为这是因为我已经为任何位置设置了身份验证,并且瓷砖位于其下方。我将如何设置为只要求对着陆页进行身份验证?
server {
listen 80;
listen [::]:80;
root /var/www/domain.org.uk/public_html;
index index.html;
server_name domain.org.uk www.domain.org.uk map.domain.org.uk;
access_log /var/log/nginx/domain.org.uk.access.log;
error_log /var/log/nginx/domain.org.uk.error.log;
# auth_basic "Server level Password required to proceed";
# auth_basic_user_file /etc/nginx/conf.d/.htpasswd;
location /geoserver/gwc/service/wmts {
auth_basic off;
#also tested without auth_basic off;
proxy_set_header Host $http_host;
proxy_set_header X-Real-IP $remote_addr;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_pass http://localhost:8080/geoserver/gwc/service/wmts;
}
location / {
try_files $uri $uri/ =404;
auth_basic "Location level Password required to proceed";
auth_basic_user_file /etc/nginx/conf.d/.htpasswd;
}
}
【问题讨论】:
标签: amazon-ec2 geoserver nginx-location nginx-config