【问题标题】:Worklight Console initialization failed.Logged Exception: org.hsqldb.HsqlException: Out of MemoryWorklight 控制台初始化失败。记录的异常:org.hsqldb.HsqlException:内存不足
【发布时间】:2015-03-05 10:12:12
【问题描述】:

当我尝试在 IBM Worklight 环境中部署我的应用程序时出现以下错误。突然我遇到了这个错误,但之前它运行良好。

能否请任何人帮助我,我在项目中是否有任何设置。

错误是:

[AUDIT   ] CWWKG0016I: Starting server configuration update.
[AUDIT   ] CWWKG0017I: The server configuration was successfully updated in 0.100 seconds.
[AUDIT   ] CWWKT0017I: Web application removed (default_host): http://ADMINIB-9PGB9N2.in.ibm.com:10080/GDMSLoginApp/
[AUDIT   ] CWWKZ0009I: The application GDMSLoginApp has stopped successfully.
[AUDIT   ] CWWKG0016I: Starting server configuration update.
[AUDIT   ] CWWKG0017I: The server configuration was successfully updated in 0.061 seconds.
[AUDIT   ] CWWKT0016I: Web application available (default_host): http://ADMINIB-9PGB9N2.in.ibm.com:10080/GDMSLoginApp/
[ERROR   ] out of memory processing logC:\GDMS\GDMSmobileMenu2\WorklightServerConfig\servers\worklight\workarea\org.eclipse.osgi\bundles\72\data\temp\default_node\SMF_WebContainer\GDMSLoginApp\GDMSLoginApp/hsqldb/WRKLGHT line: 4
Java heap space
[ERROR   ] could not reopen database
Out of Memory
[ERROR   ] FWLSE0188E: Failed to connect to HSQL database : Cannot create PoolableConnectionFactory (Out of Memory) [project GDMSLoginApp]
[ERROR   ] FWLST0003E: ========= Failed starting project /GDMSLoginApp [project GDMSLoginApp]
Error creating bean with name 'txManager' defined in URL [wsjar:file:/C:/GDMS/GDMSmobileMenu2/WorklightServerConfig/shared/resources/worklight-jee-library-6.1.0.jar!/conf/core.xml]: Cannot resolve reference to bean 'brokerSessionFactory' while setting bean property 'entityManagerFactory'; nested exception is org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'brokerSessionFactory' defined in URL [wsjar:file:/C:/GDMS/GDMSmobileMenu2/WorklightServerConfig/shared/resources/worklight-jee-library-6.1.0.jar!/conf/spring-server-core.xml]: Cannot resolve reference to bean 'rssBrokerDS' while setting bean property 'dataSource'; nested exception is org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'rssBrokerDS' defined in URL [wsjar:file:/C:/GDMS/GDMSmobileMenu2/WorklightServerConfig/shared/resources/worklight-jee-library-6.1.0.jar!/conf/spring-server-core.xml]: Cannot resolve reference to bean 'worklight-direct' while setting bean property 'targetDataSource'; nested exception is org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'worklight-direct' defined in URL [wsjar:file:/C:/GDMS/GDMSmobileMenu2/WorklightServerConfig/shared/resources/worklight-jee-library-6.1.0.jar!/conf/spring-server-core.xml]: Invocation of init method failed; nested exception is org.apache.commons.dbcp.SQLNestedException: Cannot create PoolableConnectionFactory (Out of Memory)
[AUDIT   ] CWWKZ0001I: Application GDMSLoginApp started in 1.834 seconds.
[ERROR   ] SRVE0315E: An execption occurred: com.ibm.ws.webcontainer.webapp.WebAppErrorReport: javax.servlet.ServletException: Worklight Console initialization failed.Logged Exception: org.hsqldb.HsqlException: Out of Memory
    at com.worklight.core.auth.impl.AuthenticationFilter.verifyServletInitialized(AuthenticationFilter.java:305)
    at com.worklight.core.auth.impl.AuthenticationFilter.doFilter(AuthenticationFilter.java:111)
    at com.ibm.ws.webcontainer.filter.FilterInstanceWrapper.doFilter(FilterInstanceWrapper.java:194)
    at [internal classes]
Caused by: javax.servlet.ServletException: Worklight Console initialization failed.Logged Exception: org.hsqldb.HsqlException: Out of Memory
    ... 5 more

【问题讨论】:

    标签: eclipse ibm-mobilefirst worklight-studio


    【解决方案1】:

    这里的问题是日志中的以下内容:

    记录的异常:org.hsqldb.HsqlException:内存不足

    尝试增加 Eclipse 的可用内存。

    1. 关闭 Eclipse
    2. 打开位于 Eclipse 安装文件夹中的 eclipse.ini
    3. 在文件中找到以下内容(数字可能不同):

      -vmargs
      -Xms128m
      -Xmx512m

    将数字增加到 512 或 1024 并重新打开 Eclipse。

    【讨论】:

    • 您好伊丹,感谢您的帮助。但我仍然遇到同样的错误。我已经修改了 eclipse.ini 文件,如下所示。 -vmargs -Dosgi.requiredJavaVersion=1.5 -Dhelp.lucene.tokenizer=standard -Xms512m -Xmx1024m 你能建议我做错了什么吗?
    【解决方案2】:

    尽管更改了 eclipse.ini 中的内存设置,但我遇到了同样的问题。通过执行以下步骤解决了该问题:

    1. 通过在“服务器”选项卡中右键单击 Liberty Worklight Development Server 来停止它
    2. 右键单击它并选择“清理...”
    3. 再次启动 Liberty 服务器
    4. 根据需要重新安装您的 .adapter 和 .wlapps
    5. 再试一次

    【讨论】:

      猜你喜欢
      • 1970-01-01
      • 2014-02-14
      • 1970-01-01
      • 2015-04-19
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 2014-12-09
      相关资源
      最近更新 更多