【发布时间】:2020-01-12 01:19:43
【问题描述】:
Apache 更新后无法启动,php 更新到 7.2
我试图将我的 php 版本从 7.1 更新到 7.2,但后来 apache 没有使用它,所以我也更新了它。现在我安装了 php 7.2 和 XAMPP 7.2.22。但是当我尝试启动它时,它会说'Starting...'一会儿然后'Stopped'
error_logs 只显示这个:
[2019 年 9 月 10 日星期二 11:10:38.878211] [mpm_prefork:notice] [pid 105] AH00169: 捕捉到 SIGTERM,正在关闭
[2019 年 9 月 10 日星期二 11:11:19.745774] [mpm_prefork:notice] [pid 104] AH00163:Apache/2.4.34 (Unix) 已配置 -- 恢复正常操作
[2019 年 9 月 10 日星期二 11:11:19.866352] [core:notice] [pid 104] AH00094:命令行:'/usr/sbin/httpd -D FOREGROUND'
【问题讨论】:
-
在启动之前确定没有其他httpd进程在运行吗?
-
@Amine Zaine 和
sudo brew services list它告诉我它已停止,sudo killall httpd没有输出,sudo apachectl stop输出是httpd (no pid file) not running,当我尝试强制退出这两个时Activity Monitor others 启动。我错过了什么?
标签: macos apache homebrew php-7.2