【发布时间】:2014-06-04 08:21:52
【问题描述】:
我正在按照此处的说明在弹性 beantalks 上部署我的 ruby on rails 应用程序
http://docs.aws.amazon.com/elasticbeanstalk/latest/dg/create_deploy_Ruby_rails.html
但是创建RDS数据库时出现以下错误:
2014-04-19 18:35:49 INFO Creating RDS database named: aa8njgjixa22x5. This may take a few minutes.
2014-04-19 18:45:17 ERROR Creating RDS database: aa8njgjixa22x5 failed Reason: Cannot upgrade mysql from 5.6.13 to 5.5.33
2014-04-19 18:45:36 ERROR Stack named 'awseb-e-qzjpemepuc-stack' aborted operation. Current state: 'CREATE_FAILED' Reason: The following resource(s) failed to create: [AWSEBRDSDatabase].
2014-04-19 18:45:39 INFO Launched environment: drinkchatbackend-master. However, there were issues during launch. See event log for details.
说明: 2014-04-19 18:45:36 错误堆栈名为“awseb-e-qzjpemepuc-stack”中止操作。当前状态:“CREATE_FAILED”原因:未能创建以下资源:[AWSEBRDSDatabase]。 2014-04-19 18:45:17 错误创建 RDS 数据库:aa8njgjixa22x5 失败原因:无法将 mysql 从 5.6.13 升级到 5.5.33
运行“eb status --verbose”如下所示
RDS Database: AWSEBRDSDatabase | aa8njgjixa22x5.cuokqzbpcqzr.us-west-1.rds.amazonaws.com:3306
Database Engine: mysql 5.6.13
Allocated Storage: 5
Instance Class: db.t1.micro
Multi AZ: False
Master Username: drinkchat
Creation Time: 2014-04-19 18:40:43
DB Instance Status: available
我的 .elasticbeanstalk/optionsettings080 配置未指定 5.5.x
[aws:rds:dbinstance]
DBDeletionPolicy=Snapshot
DBEngine=mysql
DBInstanceClass=db.t1.micro
DBSnapshotIdentifier=drinkchatstaging-final-snapshot
DBUser=ebroot
我的问题:
- 为什么要更新到 mysql 5.5.33?
- 如何进行调查?我没有看到应用程序 https://console.aws.amazon.com
- 我在 Amazon RDS 控制台中找不到数据库实例。
【问题讨论】:
-
我认为这与您的弹性 beanstalk 配置有关。当您的实例已经在 5.6.x 时,其指定版本 5.5.x
-
我的配置没有指定 5.5.x [aws:rds:dbinstance] DBDeletionPolicy=Snapshot DBEngine=mysql DBInstanceClass=db.t1.micro DBSnapshotIdentifier=drinkchatstaging-final-snapshot DBUser=ebroot 我认为 RDS 支持5.6.x 已经
-
我在尝试将我的 RDS 数据库从 5.5 升级到 5.6 时遇到了类似的问题。当我尝试从升级的快照启动我的弹性 beanstalk 应用程序时,尽管我的配置中没有明确的版本限制,但它会显示此错误。
-
您说您无法“看到”该应用程序。你试过运行
eb console吗?
标签: mysql amazon-web-services amazon-ec2 amazon-elastic-beanstalk