【发布时间】:2015-08-30 06:00:24
【问题描述】:
在尝试使用 amazon s3 上传图片时,
AWSS3TransferManager.defaultS3TransferManager().upload(uploadRequest).continueWithBlock{...}
以详细模式获取日志,
AWSiOSSDKv2 [调试] AWSURLResponseSerialization.m 行:82 | [AWSJSONResponseSerializer responseObjectForResponse:originalRequest:currentRequest:data:error:] |响应头:[{ “内容长度”= 129; “内容类型”=“应用程序/x-amz-json-1.1”; 日期 =“星期日,2015 年 8 月 30 日 04:54:14 GMT”; nnCoection = 关闭; "x-amzn-ErrorMessage" = "禁止访问身份 'us-east-1:9b28176f-XXXX-XXXX-82d6-f64569ae14ce'。"; "x-amzn-ErrorType" = "NotAuthorizedException:"; “x-amzn-RequestId”=“2a1fc807-4ed3-11e5-a8b0-9368dcfb1138”; }]
我已确认存储桶访问策略具有适当的访问权限。这种错误的可能原因是什么?
【问题讨论】:
标签: amazon-web-services amazon-s3 amazon-cognito