【发布时间】:2013-11-21 16:41:57
【问题描述】:
我有许多小型 MVC 应用程序部署为 Microsoft Windows Azure 网站。这已经工作了几个月。
昨天我推出了一个新的,部署并不起眼,一切正常。但几个小时后,该网站无法访问。症状是,当浏览器尝试导航到该站点的 URL 时,它会尝试加载几分钟,然后放弃一个完全空白的页面。
我尝试停止并重新启动站点,它运行了一次,但几分钟后症状又出现了。然后我尝试停止重启,还是不行。
我将相同的应用程序部署到另外三个 URL。同样,在部署时,它们都可以正常工作,但是,它们在未来的某个时间间隔会失败。他们似乎不是一次都失败了。有时重新启动站点会解决问题,有时则不会。
重要提示:如果我等待一段时间,该网站可能会自行重新开始运行。
但是,部署四个版本的应用程序以便我们的用户可以在主版本不工作时转到备用版本并不是最佳选择。
关于我如何调试这个有什么智慧的话吗?
附加信息 2013 年 11 月 25 日: 当站点出现故障时,IIS 日志会显示 500 或 502 内部服务错误。我们自己的 MVC 代码永远不会被命中,甚至 app_start 也不会。
【问题讨论】:
-
我看到了同样的问题。我在 azure 中运行一个网站,有时我开始在网络服务器日志中看到 500 和 502 错误。当它收到这些错误时,它甚至从未到达我的 webapi 代码,因为我在应用程序日志中什么也看不到。有没有人弄清楚是什么导致了天蓝色?
标签: azure azure-web-app-service