【发布时间】:2022-02-18 15:50:03
【问题描述】:
我有一个部署到 Azure 应用服务(基于西欧/Windows)的 Asp .NET Core 3.1 应用。当我使用框架依赖部署模式时,应用程序启动顺利。
但是,当我尝试切换到自包含部署时,应用程序无法启动并且我收到一条错误消息:HTTP 错误 500.30 - ANCM In-Process Start Failure
将运行时从 win-x86 更改为 x64 并没有解决问题。
我检查了已安装的 App Server 运行时版本,看起来运行时可用(参见下面的屏幕截图)。
我做错了什么?
【问题讨论】:
-
仔细检查您的
Startup.cs和/或Program.cs文件github.com/dotnet/aspnetcore/issues/8980 -
@rak007 这不是问题,我没有双重注册,它在我的本地机器上运行良好。
标签: c# azure asp.net-core