【发布时间】:2010-09-22 23:09:03
【问题描述】:
所以在一个系统上,我的价值观非常开放:
$ ulimit -a | grep mem
max locked memory (kbytes, -l) 40000
max memory size (kbytes, -m) unlimited
virtual memory (kbytes, -v) unlimited
另一个系统有更多的限制值,但我终其一生都无法找出 32MB 的上限(尽管标签错误,但它是 32MB)的设置位置:
# ulimit -a | grep mem
max locked memory (kbytes, -l) 32
max memory size (kbytes, -m) unlimited
virtual memory (kbytes, -v) unlimited
第二个系统是 RHEL 5.5 机器。我希望为至少一个用户增加此限制——我需要更大的 APC mmap 内存分配,但如果不达到上述限制,我不能超过 30 MB,我宁愿不破解提供的 apache init 脚本。我应该在哪里尝试覆盖系统默认值,以便映射更大的内存段?为 apache 用户在 limits.conf 中执行此操作并没有多大作用;可能是因为初始化脚本没有通过 PAM 做任何事情。
【问题讨论】: