【问题标题】:Launching Spring Boot app on Amazon AWS, how to set Targeted Runtime在 Amazon AWS 上启动 Spring Boot 应用程序,如何设置 Targeted Runtime
【发布时间】:2015-03-05 12:50:21
【问题描述】:

我转换了我的项目,就像它在接受this question 的答案中一样精确

部署 .war 包(使用 Maven 构建)后,我无法启动应用程序,我查看了日志并隔离了以下部分:

Jan 07, 2015 12:12:05 PM org.apache.catalina.core.ContainerBase addChildInternal
SEVERE: ContainerBase.addChild: start: 
org.apache.catalina.LifecycleException: Failed to start component [StandardEngine[Catalina].StandardHost[localhost].StandardContext[]]
    at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:154)
    at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:901)
    at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:877)
    at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:649)
    at org.apache.catalina.startup.HostConfig.deployDirectory(HostConfig.java:1247)
    at org.apache.catalina.startup.HostConfig$DeployDirectory.run(HostConfig.java:1898)
    at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
    at java.util.concurrent.FutureTask.run(FutureTask.java:262)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
    at java.lang.Thread.run(Thread.java:745)
Caused by: java.lang.NoSuchMethodError: javax.servlet.ServletContext.getVirtualServerName()Ljava/lang/String;
    at org.apache.tomcat.websocket.server.WsServerContainer.<init>(WsServerContainer.java:147)
    at org.apache.tomcat.websocket.server.WsSci.init(WsSci.java:131)
    at org.apache.tomcat.websocket.server.WsSci.onStartup(WsSci.java:47)
    at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5479)
    at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
    ... 10 more

Jan 07, 2015 12:12:05 PM org.apache.catalina.startup.HostConfig deployDirectory
SEVERE: Error deploying web application directory /var/lib/tomcat7/webapps/ROOT
java.lang.IllegalStateException: ContainerBase.addChild: start: org.apache.catalina.LifecycleException: Failed to start component [StandardEngine[Catalina].StandardHost[localhost].StandardContext[]]
    at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:904)
    at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:877)
    at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:649)
    at org.apache.catalina.startup.HostConfig.deployDirectory(HostConfig.java:1247)
    at org.apache.catalina.startup.HostConfig$DeployDirectory.run(HostConfig.java:1898)
    at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
    at java.util.concurrent.FutureTask.run(FutureTask.java:262)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
    at java.lang.Thread.run(Thread.java:745)

以下错误似乎很重要:

Caused by: java.lang.NoSuchMethodError: javax.servlet.ServletContext.getVirtualServerName()Ljava/lang/String;

我推断我应该使用我的 Eclipse IDE 添加目标环境(因为我听说不建议手动添加 jar 和编辑文件)。

我的 Amazon AWS 实例是 Tomcat 7 Java 7 64bit,所以我在本地机器上创建了一个带有 Java 1.7 的 Tomcat 7 服务器,但不幸的是它无法选择。

它说我应该卸载一些方面,但正如您在以下屏幕截图中看到的那样,似乎没有什么适合卸载以使其与 Tomcat 7 兼容。

【问题讨论】:

  • 你使用maven还是gradle?然后确保你正在建造一场战争而不是一个罐子。此外,请求的 API 是 Servlet 2.5 API,请确保您的类路径中没有旧的 servlet-api jar...
  • 感谢您的快速反馈。我使用 Maven 并构建了一个战争包。

标签: java eclipse spring tomcat spring-boot


【解决方案1】:

我终于让它工作了。解决方案如下。

首先,我们需要在所需的服务器上分析我们的项目。

right click on the project -&gt; profile as -&gt; profile on server

现在选择您选择的服务器,如果它不可用,则必须安装它(这很简单,您下载 tar.gz 存档,解压缩并在向导中选择此目录)。

现在就像我在我的问题中尝试过的一样,选择此服务器作为目标运行时,这一次它应该会出现。

right click on the project -&gt; Properties -&gt; Targeted Runtimes -&gt; select your server -&gt; apply

在这些步骤之后,我再次构建了我的 war 包,使用 ElasticBeanstalk 将其部署在 AWS 上,并且应用程序成功运行。

【讨论】:

    猜你喜欢
    • 1970-01-01
    • 2016-08-10
    • 1970-01-01
    • 1970-01-01
    • 2018-12-02
    • 2012-07-01
    • 1970-01-01
    • 2017-07-17
    • 1970-01-01
    相关资源
    最近更新 更多