【问题标题】:XAMPP Doesn't Start: SSH Not AccesibleXAMPP 无法启动:SSH 无法访问
【发布时间】:2019-03-16 13:53:06
【问题描述】:

所以基本上,我正在尝试学习如何使用 XAMPP 来制作一个带有 MySQL 的 php 服务器。但是,当我尝试启动它时,启动按钮不起作用。由于某种原因,该按钮呈灰色显示。

控制菜单的图像:https://imgur.com/a/v4O1GZ2

当我尝试从常规选项卡启动服务器时,它显示一个黄点,表示它正在启动(此处图片:https://imgur.com/a/VEkRES2),完成后,它显示此错误消息:https://imgur.com/a/Zu6hTgi

单击显示详细信息时出现的错误:无法启动堆栈:ssh 不可访问

日志:

INFO: Starting "XAMPP" stack
ERROR: Error starting "XAMPP" stack: cannot start stack: ssh not accessible`

我什么都试过了;我尝试重新安装,我尝试删除我的 ~/.bitnami 文件夹,但没有任何效果。

【问题讨论】:

    标签: php mysql apache xampp


    【解决方案1】:

    我昨晚偶然发现了这个帖子,得知这是因为我使用了CHMOD 777,不幸打破了XAMPP。

    所以想分享一下我是如何“解决”这个问题的(拯救了我的文件),而没有最近的 Time Machine 备份,以防它可能对其他人有所帮助。

    Step 1: 
    Copy the virtual XAMPP machine (machine.qcow2) in terminal
    
    ‘$ cd .bitnami/stackman/machines/xampp/vm’
    
    Now '$ open .' and move the 'machine.qcow2' file to e.g. downloads.
    
    Step 2:
    Delete the .bitnami folder.
    
    Step 3:
    Delete and re-install XAMPP.
    
    Step 4:
    Launch XAMPP and mount the image, then move machine.qcow2 file into '/opt/lamp/htdocs' using Finder.
    
    Step 5: 
    Install qemu-utils and p7zip-full
    
    '$ sudo apt-get install qemu-utils'
    '$ sudo apt-get install p7zip-full'
    
    Step 6:
    Go into the 'htdocs' directory and convert machine.qcow2 to machine.iso with qemu
    
    '$ cd /opt/lampp/htdocs'
    '$ qemu-img convert image.qcow2 image.iso'
    
    Step 7: 
    'Unzip' the .iso file
    
    '$ 7z x image.iso'
    

    就是这样!如果你现在'$ ls',你会看到你的旧文件!

    然后我使用7z 用旧文件制作了一个 Zip 备份文件夹,将7z 移动到我的桌面,删除并重新安装了XAMPP。清除新的“htdocs”并再次解压缩文件。

    这花了我大约半个晚上才弄清楚,所以希望它对某人有用!

    【讨论】:

      【解决方案2】:

      也许您需要更改端口。有时不同的程序使用相同的端口,它不能正常工作。尝试更改端口。

      Changing ports Xammp

      【讨论】:

        猜你喜欢
        • 2023-03-24
        • 2017-07-01
        • 2022-01-25
        • 2013-08-13
        • 2012-11-29
        • 2013-11-05
        • 2018-02-28
        相关资源
        最近更新 更多