【发布时间】:2020-04-10 01:24:56
【问题描述】:
我知道这个网站上有一些像我这样的问题,我尝试了所有这些问题来解决我的问题但是我失败了,所以我提出了新问题。
当我打开 XAMPP 并单击启动 MySQL 按钮时,它给了我一些错误。我之前也启动过,现在不行了。
4:29:11 PM [mysql] Error: MySQL shutdown unexpectedly.
4:29:11 PM [mysql] This may be due to a blocked port, missing dependencies,
4:29:11 PM [mysql] improper privileges, a crash, or a shutdown by another method.
4:29:11 PM [mysql] Press the Logs button to view error logs and check
4:29:11 PM [mysql] the Windows Event Viewer for more clues
4:29:11 PM [mysql] If you need more help, copy and post this
4:29:11 PM [mysql] entire log window on the forums
这是错误日志的内容:
2019-12-17 16:25:22 0 [ERROR] mysqld.exe: Aria engine: log data error last_log_page: (1,0x2000) is
less than checkpoint page: (1,0x4000)
2019-12-17 16:25:22 0 [ERROR] mysqld.exe: Aria engine: log initialization failed
2019-12-17 16:25:22 0 [ERROR] Plugin 'Aria' init function returned error.
2019-12-17 16:25:22 0 [ERROR] Plugin 'Aria' registration as a STORAGE ENGINE failed. InnoDB: using atomic writes.
2019-12-17 16:25:22 0 [Note] InnoDB: Mutexes and rw_locks use Windows interlocked functions
2019-12-17 16:25:22 0 [Note] InnoDB: Uses event
2019-12-17 16:25:22 0 [Note] InnoDB: Compressed tables use zlib 1.2.11
2019-12-17 16:25:22 0 [Note] InnoDB: Number of pools: 1
2019-12-17 16:25:22 0 [Note] InnoDB: Using SSE2 crc32 instructions
2019-12-17 16:25:22 0 [Note] InnoDB: Initializing buffer pool, total size = 16M, instances = 1, chunk size = 16M
2019-12-17 16:25:22 0 [Note] InnoDB: Completed initialization of buffer pool
2019-12-17 16:25:23 0 [Note] InnoDB: 128 out of 128 rollback segments are active.
2019-12-17 16:25:23 0 [Note] InnoDB: Creating shared tablespace for temporary tables
2019-12-17 16:25:23 0 [Note] InnoDB: Setting file C:\xampp\mysql\data\ibtmp1' size to 12 MB.Physically writing the file full; Please wait ...
2019-12-17 16:25:23 0 [Note] InnoDB: File 'C:\xampp\mysql\data\ibtmp1' size is now 12 MB.
2019-12-17 16:25:23 0 [Note] InnoDB: Waiting for purge to start
2019-12-17 16:25:23 0 [Note] InnoDB: 10.4.8 started; log sequence number 113962; transaction id 9
2019-12-17 16:25:23 0 [Note] InnoDB: Loading buffer pool(s) from C:\xampp\mysql\data\ib_buffer_pool
2019-12-17 16:25:23 0 [Note] Plugin 'FEEDBACK' is disabled.
2019-12-17 16:25:23 0 [Note] InnoDB: Buffer pool(s) load completed at 191217 16:25:23
2019-12-17 16:25:23 0 [ERROR] Could not open mysql.plugin table. Some plugins may be not loaded
2019-12-17 16:25:23 0 [ERROR] Failed to initialize plugins.
2019-12-17 16:25:23 0 [ERROR] Aborting
我之前尝试过这些解决方案,但我的问题没有解决
- 删除 ibdata1 文件。
- 删除mysql/data/中的所有随机文件(实际数据库文件夹除外)
- 在 mysql 配置文件 (my.ini) 的 [mysqld] 下面添加 innodb_force_recovery = 4
- 删除 ibdata1 & ib_logfile*(ib_logfile0,ib_logfile1,ib_logfile101) 文件
- 更改 C:\xampp\mysql\data 中所有文件(如 test_db)的位置以进行测试
- 将mysql服务器端口改为“3307,3308,9999,6542”
在这个地方-->
[mysqld]
port=3306
and
[client]
port=3306
socket="C:/xampp/mysql/mysql.sock"
感谢您的帮助。
【问题讨论】:
-
已经完成了 1. 和 2. 和 4. 我建议你已经烧毁了所有的桥梁。我想你只需要重新安装 XAMPP 并重新开始。希望您对正在处理的数据库进行了备份
-
如果您打开 XAMPP 控制面板,然后点击 netstat 按钮,它将显示哪个应用程序正在使用端口 3306。
-
你是说它已经奏效并且你在mariaDB中做了一些工作,但现在它不起作用?还是在第一次/第二次尝试启动 mariaDB 时发生这种情况
-
@RiggsFolly 我昨天正在使用 mysql,但现在...
-
ARIA 存储引擎是 mariaDB 用于其自己的内部数据库的。如果那不起作用,那么 mariaDB 也不是