【问题标题】:starting jetty 9 faild ubuntu 12.04启动码头 9 失败 ubuntu 12.04
【发布时间】:2013-04-21 06:41:23
【问题描述】:

我在 ubuntu 服务器 12.04 上安装了 jetty (distribution-9.0.2) 从这些链接一步一步

http://degreesofzero.com/article/19

http://pietervogelaar.nl/ubuntu-12-04-install-jetty-9/

最后当我使用以下命令启动码头时:

sudo /etc/init.d/jetty start

sudo service jetty start

我收到以下错误

Starting Jetty: grep: /var/run/jetty.state: No such file or directory

【问题讨论】:

    标签: jetty ubuntu-12.04


    【解决方案1】:

    我在 Debian 6 服务器上遇到了同样的问题。从我的角度来看,此问题和上述文章的解决方法是:

    1. 使用 JETTY_ARGS=jetty.port=8080 代替 JETTY_PORT
    2. 向 /etc/init.d/jetty 添加属性:JETTY_PID=/opt/jetty/jetty.state

    如果您有任何问题,请告诉我

    【讨论】:

    • tanQ evgeniy,我添加了 jetty_pid,但我得到另一个错误,只是告诉启动失败,然后我运行这个 bash [bash --debugger ./jetty start] 并且码头启动没有错误,之后[jetty start] 工作正常
    【解决方案2】:

    我已经使用最新版本的 jetty 对此进行了彻底测试,并且运行良好。 jetty.sh 脚本最近发生了一些变化。但是,这些更改对我来说看起来不错,并且在最新版本中对我来说效果很好。

    Evgenly 是对的,JETTY_PORT 已被弃用(有关详细信息,请参阅 jetty.sh 中的 cmets),但它也适用于我使用 JETTY_PORT 而不是 JETTY_ARGS 来定义非标准端口。

    如果您还没有这样做,请尝试此处的最新版本: http://download.eclipse.org/jetty/

    如果 jetty.sh 报告启动失败,您通常会在 JETTY_HOME/logs 目录内的 stderrout.log 中找到原因(除非您更改了日志记录配置)。

    【讨论】:

      猜你喜欢
      • 2014-05-25
      • 1970-01-01
      • 2017-01-05
      • 1970-01-01
      • 2013-01-26
      • 2014-04-25
      • 1970-01-01
      • 2017-03-04
      • 1970-01-01
      相关资源
      最近更新 更多