【问题标题】:Display contents of domain folder on sub domain root在子域根目录显示域文件夹的内容
【发布时间】:2013-05-17 18:53:53
【问题描述】:

我在主域的根目录下有一个网站,我们称之为 domain(dot)com,这个网站通过 htaccess 运行一个基于模板的系统,类似于 wordpress。 在那里我有一个名为 domain(dot)com/forum/ 的部分,该文件夹不存在,因为它是通过模板系统和 htaccess 管理的。

我正在尝试找到一个解决方案,我在上面的同一域上创建一个子域,并且所有工作都好像它们在 domain(dot)com/forum/ 上,但实际上在 forum(dot)domain(dot) 上com.

由于主站点上的 htaccess 文件控制了所有结构,这实际上可能吗?

从符号链接到虚拟主机文档根目录,我到处搜索,但找不到解决方案。

任何指导将不胜感激。

谢谢

【问题讨论】:

    标签: php linux .htaccess hosting vhosts


    【解决方案1】:

    在forum.domain.com公共目录文件夹中添加一个htaccess文件并添加以下内容:

    RewriteEngine On
    RewriteRule ^(.*)$ domain.com/forum/$1 [NC,L]
    

    【讨论】:

    • 感谢您的快速响应,htaccess 代码导致 500 服务器错误。是不是因为我在主站点根目录下的唯一文件是 .htaccess 和 index.php。我没有名为 /forum/ 的物理目录?
    • 在此处发布您的错误日志消息。应该在logs/error_log中
    • 您好,这是错误日志...[Thu May 23 06:04:38 2013] [error] [client 109.144.237.206] Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace.
    猜你喜欢
    • 2012-11-24
    • 2017-08-23
    • 1970-01-01
    • 1970-01-01
    • 2013-04-06
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    相关资源
    最近更新 更多