【发布时间】:2014-01-16 23:17:05
【问题描述】:
我测试了 nginx,但遇到了一个严重的问题。不知何故,位置标签无法捕捉到我的 uri。当浏览器或我手动尝试访问本地主机上的 /favicon.ico 时,它只会引发 404 错误。配置如下代码:
server {
listen 80;
server_name localhost;
root www;
#charset koi8-r;
#access_log logs/host.access.log main;
location / {
index index.html index.php;
}
location = /favicon.ico {
alias alias /assets/images/favicon.ico;
}
...错误日志如下所示:
2014/01/17 00:05:18 [错误] 7408#10036: *82 CreateFile() "C:\Users\user\Webb\nginx/www/favicon.ico" 失败 (2: FormatMessage()错误:(15105)),客户端:127.0.0.1,服务器:本地主机,请求:“GET /favicon.ico HTTP/1.1”,主机:“本地主机”
日志证明location块被忽略了,因为nginx查找文件的路径不是别名指向的那个。
【问题讨论】: