【问题标题】:phpMyAdmin Error #1649 unknown localephpMyAdmin 错误 #1649 未知语言环境
【发布时间】:2017-06-18 02:12:33
【问题描述】:

我在 localhost (WAMP 3.0.6) 上的 phpMyAdmin 中检查了一些东西,突然我被以下错误锁定:

Error

SQL query: Edit

SET lc_messages = 'en_US';

MySQL said:
#1649 - Unknown locale: 'en_US'

我只是环顾四周,我相信当我在“常规设置”下的“服务器连接排序规则”下拉列表中意外选择了另一个值时发生了错误,不是默认设置。

语言在my.ini 设置为lc_messages = 'en_US';

我尝试重新安装 WAMP,但没有成功。每次我尝试登录 phpMyAdmin 时仍然会出现该错误。所以我不确定实际的问题是什么。

谢谢。

【问题讨论】:

  • 尝试重启服务器?
  • 我假设卸载并重新安装 WAMP 会作为服务器重启?我也尝试在重新安装后重新启动所有服务。但不能修复 phpMyAdmin 错误。
  • 你的语言环境是什么
  • 您是否让安装完成?安装中完成的最后一件事是运行 MYSQL 安装/初始构建
  • 我不太了解这个错误,也不太确定语言环境是什么。我使用与之前安装它之前工作正常的相同程序重新安装。 WAMP 服务器图标也显示为绿色。我的本地网站都可以正常工作。唯一的问题是,由于该错误,我无法访问 phpMyAdmin,例如创建一个新的数据库。

标签: php mysql phpmyadmin wamp


【解决方案1】:

尝试清除您的 phpMyAdmin cookie(通常以“pma”开头)。实际上,您应该只需要清除 'pma_lang' cookie。

我不确定您的问题的根本原因是什么(可能您的 MySQL 没有安装 en_US 语言包,或者它可能是旧的 MySQL 版本或其他东西)。有点奇怪,'en_US' 是在 my.ini 中定义的,但在被 phpMyAdmin 调用时却报错。

但是,通过更改语言下拉菜单,phpMyAdmin 现在认为您想要显式强制使用特定语言(在这种情况下为 en_US,但它可以是任何语言环境),因此当它连接到 MySQL 时,它会首先尝试要做的是强制语言环境,这会导致错误。通过清除 'pma_lang' cookie,您将重置 phpMyAdmin 中的语言首选项,它应该返回使用系统默认值,并且在连接到 MySQL 时不强制执行任何操作,这将清除错误消息。

更多关于为什么会发生这种情况的问题,如果您对此感兴趣,可能应该直接向 WAMP 人员提问,因为这似乎是他们的工具包的一个小故障,但至少这可以让您的 phpMyAdmin 再次工作。

【讨论】:

  • 不敢相信这么简单,只需要删除 cookie。 Stack Overflow 总是让我惊叹
  • @J3STER 当然,事后看来这很简单,但也不明显,这就是为什么我们都难过时来到这里的原因 :-) 我很高兴知道它有帮助。
猜你喜欢
  • 1970-01-01
  • 2013-11-26
  • 1970-01-01
  • 1970-01-01
  • 1970-01-01
  • 1970-01-01
  • 2013-01-10
相关资源
最近更新 更多