【问题标题】:SSIS : Deployment failed on Changing Protection Level stage with XML ErrorSSIS:在更改保护级别阶段部署失败并出现 XML 错误
【发布时间】:2014-10-09 04:07:28
【问题描述】:

我使用的是 SQL Server Data Tools 2012 版本和项目部署模型。

我在更改客户端测试环境中部署的保护级别阶段时遇到错误。

由于错误 0xC0011008“从 XML 加载时出错。无法为此问题指定更多详细的错误信息,因为没有传递任何事件对象来存储详细的错误信息。”。当 CPackage::LoadFromXML 失败时会发生这种情况。

我已创建项目参数以提供 Sharepoint 站点连接字符串和 SQL Server 数据库连接字符串。

(SSIS 包概述:从 SharePointLists 中提取数据,然后导入 SQL 表。)

当我搜索这个错误时,发现了很多方法来设置包部署模型的包配置。

我在 Package 的配置中缺少什么,因此它无法加密解密提到的 UserID 和 Password 详细信息?

我已经浏览了许多论坛以明确了解这一点,但还没有找到任何解决方案。

客户端环境中的集成服务版本和部署实用程序版本是否也相同?我应该在哪里检查它们的安装版本?

ProtectionLevel 设置为:DontSaveSensitive

请帮忙。

谢谢,

米塔尔。

【问题讨论】:

  • 我也面临同样的问题。请高手帮忙

标签: sql sql-server xml ssis ssis-2012


【解决方案1】:

对我来说,问题是 sql 定位的版本。当我尝试部署到 sql server 2012 时,sql 目标是 2016。所以只需从 VS 项目属性更改目标就可以了。

【讨论】:

    【解决方案2】:

    我遇到了“更改保护级别失败”的问题。早些时候,当我从目录运行包时,我遇到了包版本问题。那是因为我在我的开发环境中使用了最新的 sql server 数据工具,并且在开发环境中的版本是 8,但在服务器中它需要 6。但是即使在使用 sql 2012 版本的服务器部署之后,问题仍然存在。后来我按照 patricgh 的建议更改了项目属性中的目标版本,效果很好。

    【讨论】:

      【解决方案3】:

      我的情况略有不同,但大致相同。

      本地 SQL 服务器版本:SQL Server 2016

      服务器 SQL 服务器版本:SQL Server 2012

      如果我在本地打开 ISPAC 文件,包将转换为版本 8。但在服务器上,它的版本为 6。因此,如果您尝试在 SQL Server 2012 上部署版本 8 包,您将获得以下错误。

      在更改保护级别阶段部署失败并出现 XML 错误

      要解决此问题,请打开服务器上的 ISPAC 文件并构建它。然后在服务器上部署包。它应该成功部署。希望这会有所帮助。

      【讨论】:

        猜你喜欢
        • 1970-01-01
        • 2020-09-12
        • 1970-01-01
        • 1970-01-01
        • 2012-01-10
        • 1970-01-01
        • 2022-06-21
        • 2012-06-08
        • 2015-03-17
        相关资源
        最近更新 更多