【问题标题】:XAMPP MySQL shutdown unexpectedly - no error in logsXAMPP MySQL 意外关闭 - 日志中没有错误
【发布时间】:2020-02-07 05:29:19
【问题描述】:

XAMPP 今天早上早些时候工作正常,但是在进行了一些 Wordpress 插件更新并与 Github 和 Pantheon 重新同步后,MySQL 现在将启动,运行几秒钟,然后关闭。在查看 mysql_error.log 时,我看到了这个:

InnoDB: using atomic writes.
2019-10-09 12:41:23 0 [Note] InnoDB: Mutexes and rw_locks use Windows interlocked functions
2019-10-09 12:41:23 0 [Note] InnoDB: Uses event mutexes
2019-10-09 12:41:23 0 [Note] InnoDB: Compressed tables use zlib 1.2.11
2019-10-09 12:41:23 0 [Note] InnoDB: Number of pools: 1
2019-10-09 12:41:23 0 [Note] InnoDB: Using SSE2 crc32 instructions
2019-10-09 12:41:23 0 [Note] InnoDB: Initializing buffer pool, total size = 16M, instances = 1, chunk size = 16M
2019-10-09 12:41:23 0 [Note] InnoDB: Completed initialization of buffer pool
2019-10-09 12:41:23 0 [Note] InnoDB: 128 out of 128 rollback segments are active.
2019-10-09 12:41:23 0 [Note] InnoDB: Creating shared tablespace for temporary tables
2019-10-09 12:41:23 0 [Note] InnoDB: Setting file 'C:\xampp\mysql\data\ibtmp1' size to 12 MB. Physically writing the file full; Please wait ...
2019-10-09 12:41:23 0 [Note] InnoDB: File 'C:\xampp\mysql\data\ibtmp1' size is now 12 MB.
2019-10-09 12:41:23 0 [Note] InnoDB: Waiting for purge to start
2019-10-09 12:41:23 0 [Note] InnoDB: 10.4.6 started; log sequence number 113917; transaction id 9
2019-10-09 12:41:23 0 [Note] InnoDB: Loading buffer pool(s) from C:\xampp\mysql\data\ib_buffer_pool
2019-10-09 12:41:23 0 [Note] Plugin 'FEEDBACK' is disabled.
2019-10-09 12:41:23 0 [Note] InnoDB: Buffer pool(s) load completed at 191009 12:41:23
2019-10-09 12:41:23 0 [Note] Server socket created on IP: '::'.

我没有看到任何明显的错误。

对于如何获得更详细的错误信息或如何解决此问题有任何想法吗?谢谢!

更新

在 Windows 事件查看器中,我能够得到以下错误描述:

Slave I/O: Fatal error: Invalid (empty) username when attempting to connect to the master server. Connection attempt terminated. Internal MariaDB error code: 1593

【问题讨论】:

  • 我试过了,然后我也尝试删除 ib_logfile0 和 ib_logfile1 文件。没有区别。
  • 由于找不到解决方案,我继续卸载并重新安装了xampp。新安装运行良好。
  • 有更新可能更好(?因为它不会删除 ibdata1,这会危及您的数据?)回答最初由@earid 链接的问题:stackoverflow.com/a/61859561/2466193。

标签: mysql wordpress xampp


【解决方案1】:

复制此文件:

aria_log.00000001
aria_log_control
ib_buffer_pool
ib_logfile0
ib_logfile1
ibdata1
ibtmp1
multi-master.info

来自:xampp\mysql\backup

到:xampp\mysql\data

【讨论】:

  • 嗨,伊戈尔,感谢您的建议。自发布以来,我最终切换到 WAMPServer 并且最终将使用 Docker 容器实例进行所有开发以避免这种类型的头痛(尽管我知道 Docker 配置也不是没有它自己的头痛)。无论如何,再次感谢您花时间查看我的日志并提供您的帮助。我真的很感激!
  • @Igor L 我遇到了同样的问题,移动这些文件就可以了。有谁知道是什么原因导致这个问题?
  • 这个答案stackoverflow.com/a/61859561/2466193 的作用非常相似,但可能会好一点,因为它不会删除您的 ibdata1(可能很危险?)并制作您宝贵数据的“旧”副本首先(如果修复失败,您可以回滚)。
猜你喜欢
  • 1970-01-01
  • 2021-01-04
  • 2017-10-01
  • 2018-03-29
  • 2013-02-16
  • 2019-01-25
  • 2018-04-24
  • 1970-01-01
  • 2021-03-18
相关资源
最近更新 更多