【问题标题】:How can I host ASP.NET 5 (vNext) MVC 6 project under IIS classic mode pool如何在 IIS 经典模式池下托管 ASP.NET 5 (vNext) MVC 6 项目
【发布时间】:2015-02-04 15:22:36
【问题描述】:

使用kpm pack 制作了一个包 尝试在经典管道模式下设置 IIS7

我一直收到

HTTP Error 403.14 - Forbidden
The Web server is configured to not list the contents of this directory.

已经尝试过

  • 将 aspnet_isapi.dll 添加到 web.config/system.webServer/handlers 部分
  • 为web.config/system.webServer/handlers 部分添加runAllManagedModulesForAllRequests="true"

ISAPI 和 CGI​​ 限制中的所有 aspnet_isapi.dll 都是允许的

是否可以在 IIS 经典模式管道下托管 vNext ASP.NET 应用程序?

【问题讨论】:

  • 我只能让它在集成模式下工作。为什么要尝试使用经典?我也认为错误消息是:由于 Web 服务器上的 ISAPI 和 CGI​​ 限制列表设置,无法提供您请求的页面。
  • 我也让它只在集成模式下工作。
  • @yhax 经典模式支持是我们的环境要求。更新了问题。

标签: iis-7 httphandler asp.net-core asp.net-core-mvc


【解决方案1】:

根据当前的发展,我认为这在经典 IIS 模式下不起作用。它只能在 IIS 集成模式下工作。

给我几个理由。

  1. 直到 ASP.net MVC 5 请求处理是通过 MVC Handler 完成的,它没有像 OWIN 那样与管道集成。

  2. 在 ASP.net vnext (MVC6) 中,请求处理更像 OWIN。它就像与 IIS 的集成 piplline 紧密集成(在 Katana 中,如果您在经典模式下运行,它会报错)

【讨论】:

    猜你喜欢
    • 2015-02-04
    • 2016-01-12
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 2015-02-15
    • 2015-07-31
    • 1970-01-01
    • 2015-01-29
    相关资源
    最近更新 更多