【问题标题】:Static web application in docker using nginx - localhost refused to connect使用 nginx 的 docker 中的静态 Web 应用程序 - localhost 拒绝连接
【发布时间】:2020-12-03 06:21:31
【问题描述】:

Docker 文件包含以下命令

FROM nginx
COPY . /usr/share/nginx/html

为了构建我的 docker 镜像,我使用了以下命令

docker build -t <tagName>/img .

运行 docker 镜像

docker run -p 80:8080 <tagName>/img

但我无法在浏览器中启动我的静态网站。我得到了

This site can’t be reached
localhost refused to connect.

【问题讨论】:

    标签: docker nginx web web-deployment web-application-project


    【解决方案1】:

    您在此处将端口 80 映射到 8080:docker run -p 80:8080 &lt;tagName&gt;/img,因此要访问您的应用只需使用地址:'localhost:80'(或者您可以省略端口,因为 80 是浏览器中使用的默认端口)

    【讨论】:

      【解决方案2】:

      虽然 Kimi Marie 完全正确,但 nginx Dockerfile 在容器内提供了 80 端口。所以我假设你想将容器的端口 80 映射到本地端口 8080。你只需要翻转参数就像

      docker run -p 8080:80 <tagName>/img
      

      【讨论】:

      猜你喜欢
      • 2023-03-09
      • 2022-01-10
      • 1970-01-01
      • 1970-01-01
      • 2020-02-13
      • 2021-06-27
      • 2017-05-20
      • 1970-01-01
      • 1970-01-01
      相关资源
      最近更新 更多