【问题标题】:Web Deploy Fails with ERROR_EXCEEDED_MAX_SITE_CONNECTIONSWeb 部署失败并显示 ERROR_EXCEEDED_MAX_SITE_CONNECTIONS
【发布时间】:2014-04-26 12:08:44
【问题描述】:

当我使用 Web 部署从 Visual Studio 部署我的解决方案(DNN 解决方案)时,我获得了一些文件(平均 30 个)的成功,然后我收到错误:

Error   102 Web deployment task failed. (The maximum number of connections for this site has been exceeded.  Learn more at: h**p://go.microsoft.com/fwlink/?LinkId=221672#ERROR_EXCEEDED_MAX_SITE_CONNECTIONS.)     0   0   h**p://mylocalhostwebsite/mywebsitename/"

我阅读了我能获得的所有内容,但无法找到有效的解决方案。

我在 Windows 2012 上运行我自己的专用服务器(在 Windows azure 上)。我的开发环境在 Windows 8 上运行,我正在使用 VS.NET 2013 Ultimate 进行部署

服务器很干净,只有一个网站,甚至没有生命(除了我,唯一的开发人员,没有人在访问服务器)

一旦发生此错误,Web 部署将持续失败并出现相同的错误(不再有 30 个左右的文件)...直到我重新启动服务器。

我检查了网络服务器,一切似乎都完好无损……

我没有将数据库部署为流程的一部分

【问题讨论】:

  • 我确实读过这个。我在家里尝试过这个,通过我的移动连接和星巴克互联网。所有人都给了我相同的结果。它们会工作一段时间,然后我必须重新启动服务器才能使其再次工作。

标签: azure visual-studio-2013 webdeploy


【解决方案1】:

我尝试到处寻找发生这种情况的原因,但还没有找到答案。当它发生时,能够再次发布的最快方法是终止 WMSVC 进程并重新启动它。为了减少手动执行此操作,我每天午夜都会使用批处理文件和 Windows 任务计划程序终止 WMSVC 进程。

ECHO OFF
for /f "tokens=2 delims=," %%B in ('tasklist /fi "Imagename eq wmsvc.exe" /fo csv') do @echo %%B >processkill.txt
set /p taskid=<processkill.txt
TASKKILL /f /pid %taskid%
exit

这会在与您正在运行的批处理文件相同的位置创建一个文本文件,并使用 WMSVC 进程的进程 ID,然后将其终止。确保将进程设置为自动启动。

此外,我正在调查这是否是一个更永久的修复 - 将以下内容添加到注册表:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\IIS Extensions\MSDeploy\3] "MaxSiteConnections"=dword:00000010

【讨论】:

    【解决方案2】:

    我在 Windows Server 2012 R2 中的 IIS 上遇到了同样的问题。

    我已经用这个post解决了它

    更新

    • 转到 IIS 服务器
    • 选择您的 IIS 服务器,在功能视图中选择管理服务
    • 在操作下,单击重新启动。

    所以我已经重新启动了服务器并且工作正常......

    【讨论】:

    • 虽然此链接可能会回答问题,但最好在此处包含答案的基本部分并提供链接以供参考。如果链接页面发生更改,仅链接答案可能会失效。 - From Review
    • 谢谢! @AndreiM 提出建议。
    • 这不是解决方案。这是一种解决方法。出现问题后的一种恢复方式。挑战在于找出问题*导致*的原因,以便避免问题。
    猜你喜欢
    • 2013-08-17
    • 1970-01-01
    • 1970-01-01
    • 2018-01-25
    • 2013-03-10
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    相关资源
    最近更新 更多