【问题标题】:fail to start mysql(mariadb)无法启动 mysql(mariadb)
【发布时间】:2018-08-30 19:13:38
【问题描述】:

我一直在花费数小时来解决连接 mysql 的问题,以便最终使用 mariadb。这是一种情况。

情况:

1.我用的是macbook,对电脑编程不是很熟悉。 我试图连接java eclipse和mariadb。所以我在网上查了一下。 同时,我打开终端并使用启动我的mysql

mysql.server start

它奏效了。我应该下载 mariaddb.2.2 jar 来将它与 eclipse 连接起来,但我错误地下载了“mariadb-10.2.12-osx10.13-x86_64.pkg”并安装了它。我也输入了

mysql.server stop

以及所有类似的东西。很多很多的事情,以至于我什至不记得了 当我发现我下载了错误的东西后,我觉得这超出了我的能力,所以我跳回去玩mariadb。

我打开终端输入

mysql.server start

直到现在,终端一直向我展示这个

.180322 00:04:47 mysqld_safe Logging to '/usr/local/var/mysql/sinjinhos-MacBook-Air-146.local.err'.
180322 00:04:47 mysqld_safe Starting mysqld daemon with databases from /usr/local/var/mysql
. ERROR! 

我仍然认为这场悲剧是因为我再次安装了 mariadb... 我真的尝试了一切,但仍然无法弄清楚。 请帮帮我!!

【问题讨论】:

  • "mysqld_safe Logging to '/usr/local/var/mysql/sinjinhos-MacBook-Air-146.local.err'"...那个文件里有什么?
  • 我希望我能回答这个问题
  • 如果您不能提供错误,没有人可以提供帮助。运行这个来查看文件的结尾:tail /usr/local/var/mysql/sinjinhos-MacBook-Air-146.local.err
  • 2018-03-22 0:36:36 140736284734272 [错误] 无法启动服务器:绑定 TCP/IP 端口。出现错误:48:地址已在使用 2018-03-22 0:36:36 140736284734272 [错误]您是否已经在端口:3306 上运行了另一个 mysqld 服务器? 2018-03-22 0:36:36 140736284734272 [错误] 中止
  • 我的错,还是不习惯这个网站。所以我运行它,它向我显示了这条消息。

标签: mysql mariadb


【解决方案1】:

从您最初的帖子中,您可以看到 mariadb 正在记录以下文件。

180322 00:04:47 mysqld_safe 记录到“/usr/local/var/mysql/sinjinhos-MacBook-Air-146.local.err”

在该文件中,您发现了以下错误。

2018-03-22 0:36:36 140736284734272 [错误] 无法启动服务器:绑定 TCP/IP 端口。出现错误:48:地址已在使用 2018-03-22 0:36:36 140736284734272 [错误]您是否已经在端口:3306 上运行了另一个 mysqld 服务器? 2018-03-22 0:36:36 140736284734272 [错误] 中止

错误的关键部分是Address already in use。在您的计算机上运行的所有监听连接的东西(如数据库或 Web 服务器)都将监听特定端口。 MySQL(以及 MariaDB)默认侦听端口 3306。重要的是你不能让多个应用程序在同一个端口上监听!

那么你从这里去哪里?我怀疑您的笔记本电脑上仍在运行 MySQL,一旦您停止它,您将能够启动一个新实例。

要检查 MySQL 是否正在运行,您可以使用以下命令:

ps -ef | grep mysql

如果此处显示任何内容,则说明它正在运行,您应该停止该服务。执行此操作的方式将根据您的安装方式而有所不同——首先尝试mysql.server stop,然后再次运行上述命令。如果它仍在运行并且您无法弄清楚,那么您可以kill 服务。不建议这样做,这会导致 MySQL 数据损坏 - 尽管如果您没有数据,那么您应该没问题。

ps -ef 的示例输出。你的应该在末尾显示 MySQL,第二列显示你可以用来终止进程的进程 ID。

    PID
    \/
0  9504  9491   0  3:44pm ttys007    0:00.00 ps -ef`

所以我会使用:

kill 9504

然后您应该能够再次启动该服务。

mysql.server start

【讨论】:

  • 首先,非常感谢。这是我在遵循您的指导后得到的。所以我输入了“ps -ef | grep mysql”,然后我有以下内容
  • 74 74 1 0 11:36PM ?? 0:01.64 /usr/local/mariadb/server/bin/mariadbd --user=_mysql --basedir=/usr/local/mariadb/server --log-basename=mariadb --plugin-dir=/usr/local/ mariadb/server/lib/plugin 501 36856 36626 0 1:02AM ttys001 0:00.01 grep mysql sinjinhos-MacBook-Air-146:~ JinhoShin$
  • 当我输入 时,错误!找不到 MariaDB 服务器 PID 文件! => 显示此消息
  • 所以你需要kill 74
  • 我建议你看看命令行教程。也许是like this。
猜你喜欢
  • 1970-01-01
  • 2017-05-16
  • 1970-01-01
  • 2015-03-03
  • 2017-05-07
  • 1970-01-01
  • 1970-01-01
  • 2018-07-24
  • 2021-03-19
相关资源
最近更新 更多