【问题标题】:AWS SES Error: x509: certificate signed by unknown authorityAWS SES 错误:x509:证书由未知机构签名
【发布时间】:2019-03-07 04:06:08
【问题描述】:

我已经用这个把头撞在桌子上了一段时间了。我是。我已经使用具有完全访问权限的 AWS 访问密钥和密钥成功地在本地发送了电子邮件。部署到暂存环境后,使用相同的访问密钥和密钥时出现错误。

RequestError: send request failed\ncaused by: Post https://email.us-east-1.amazonaws.com/: x509: certificate signed by unknown authority

请帮忙!

【问题讨论】:

  • 在您的问题中需要更多详细信息。也许展示你的程序的一部分?您认为错误来自客户端还是服务器?你能用 openssl s_client 之类的工具引发类似的错误吗?
  • 确保您的实例上安装了 ca-certificates 软件包。安装后重启你的 Go 程序。
  • @Peter 谢谢彼得,这就是我所缺少的!
  • @Peter - 发表您的评论以及更多详细信息作为答案。这将有助于其他人理解此错误的含义。

标签: amazon-web-services go amazon-ses


【解决方案1】:

如果你使用alpine docker image,例如:

FROM alpine:3.6 as alpine

RUN apk add -U --no-cache ca-certificates

FROM scratch
COPY --from=alpine /etc/ssl/certs/ca-certificates.crt /etc/ssl/certs/

添加根证书ca-certificates后,就可以正常使用了。

【讨论】:

  • 谢谢,这对我有帮助。如果您不使用多阶段 docker 文件,则只需添加 RUN apk add -U --no-cache ca-certificates
  • @Dattatray sudo apt-get install ca-certificates -y
  • Debian/Ubuntu: apt-get update && apt-get install -y --no-install-recommends ca-certificates 如果使用多阶段,则复制到同一位置。这个关于 serverfault 的答案有一个很好的其他 linux 发行版的预期位置列表serverfault.com/a/722646/443669
猜你喜欢
  • 2020-04-01
  • 1970-01-01
  • 2020-03-16
  • 1970-01-01
  • 1970-01-01
  • 2023-01-09
  • 2017-12-23
  • 2021-02-01
  • 2016-03-20
相关资源
最近更新 更多