【发布时间】:2019-03-07 04:06:08
【问题描述】:
我已经用这个把头撞在桌子上了一段时间了。我是。我已经使用具有完全访问权限的 AWS 访问密钥和密钥成功地在本地发送了电子邮件。部署到暂存环境后,使用相同的访问密钥和密钥时出现错误。
RequestError: send request failed\ncaused by: Post https://email.us-east-1.amazonaws.com/: x509: certificate signed by unknown authority
请帮忙!
【问题讨论】:
-
在您的问题中需要更多详细信息。也许展示你的程序的一部分?您认为错误来自客户端还是服务器?你能用 openssl s_client 之类的工具引发类似的错误吗?
-
确保您的实例上安装了
ca-certificates软件包。安装后重启你的 Go 程序。 -
@Peter 谢谢彼得,这就是我所缺少的!
-
@Peter - 发表您的评论以及更多详细信息作为答案。这将有助于其他人理解此错误的含义。
标签: amazon-web-services go amazon-ses