【问题标题】:How to install apxs module on apache 2.4.6如何在 apache 2.4.6 上安装 apxs 模块
【发布时间】:2013-09-05 04:22:35
【问题描述】:

我刚刚使用了apt-get update,我的apache已经更新为2.4.6。

我想安装 apxs 来编译模块,我得到这个错误

The following packages have unmet dependencies:
 apache2-prefork-dev : Depends: apache2.2-common (= 2.2.22-1ubuntu1.4) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

我该如何解决这个问题

【问题讨论】:

    标签: linux apache ubuntu apache2


    【解决方案1】:

    APC 目前与该版本不兼容。尝试在其中添加本机操作码缓存。

    【讨论】:

    • APXS 不是 APC。他们甚至没有关系。 (APXS 是用于构建和安装 Apache 模块的工具,APC 是 PHP 扩展。)
    【解决方案2】:

    要在 ubuntu 上安装 apxs,请安装apache2-dev 包。

    sudo apt install apache2-dev
    

    【讨论】:

    • sudo apt install apache2-dev 更新版本
    【解决方案3】:

    您不能在 cpanel 上安装 httpd-devel。你需要安装 ea-apache24-devel

    https://forums.cpanel.net/threads/install-httpd-devel.594631/

    【讨论】:

    【解决方案4】:

    要在 Oracle Linux 上安装 apxs,请运行:

    yum install httpd-devel

    【讨论】:

      【解决方案5】:

      在 Ubuntu 中,设置 Apache2 + PHP 时,实际上不再需要 apxs。
      您应该安装 libapache2-mod-php。
      sudo apt install apache2
      sudo apt install libapache2-mod-php

      【讨论】:

        猜你喜欢
        • 1970-01-01
        • 2014-12-22
        • 1970-01-01
        • 1970-01-01
        • 1970-01-01
        • 2017-05-26
        • 1970-01-01
        • 1970-01-01
        • 2018-04-22
        相关资源
        最近更新 更多