【问题标题】:#1293 - Incorrect table definition; there can be only one TIMESTAMP column with CURRENT_TIMESTAMP in DEFAULT or ON UPDATE clause#1293 - 表定义不正确;在 DEFAULT 或 ON UPDATE 子句中只能有一个带有 CURRENT_TIMESTAMP 的 TIMESTAMP 列
【发布时间】:2016-05-13 04:17:34
【问题描述】:

我有一个 Magento2 网站,想部署在服务器上。当我尝试将本地数据库副本导入实时 mySQL 服务器时,出现上述错误。我发现在本地系统上我有 mySQL 5.6 和 phpMyAdmin 4.4 而在实时服务器上它低于 5.6(我的主机没有显示哪个 mysql 版本)的原因。和 phpMyAdmin 3.4.11。 有没有办法解决这个问题?感谢您的 cmets 和解决方案

错误看起来像这样。 注意: 还有一些其他表,如 admin_user,我从数据库表的第二列中删除了 CURRENT_TIMESTAMP 属性和 ON UPDATE CURRENT_TIMESTAMP。

【问题讨论】:

    标签: web-deployment magento2 mysql5 mysql6


    【解决方案1】:

    MySQL 5.6 是支持的最低版本。您的服务器可能有较低的版本(请参阅https://dev.mysql.com/doc/refman/5.6/en/upgrading-from-previous-series.html)您可以检查在您的服务器上运行以下查询的版本:

    SELECT version();
    

    【讨论】:

    • 实时版本是 5.5.41-log。没有其他方法可以在实时服务器上安装 Magento2 吗?
    • 否 :( 请求 mysql 升级或切换主机。使用 5.6 的原因:github.com/magento/magento2/issues/1244
    猜你喜欢
    • 1970-01-01
    • 1970-01-01
    • 2012-06-17
    • 1970-01-01
    • 2017-04-26
    • 1970-01-01
    • 1970-01-01
    • 2014-03-16
    • 1970-01-01
    相关资源
    最近更新 更多