【问题标题】:Intermittent "Error establishing database connection" on WordPressWordPress上的间歇性“建立数据库连接时出错”
【发布时间】:2015-03-18 17:14:25
【问题描述】:

我在加载页面(在网站和控制面板上)的 10 次中可能有 1 次出现上述错误。

我还注意到,当我登录 phpMyAdmin 时,我经常会收到此错误:

#1203 - 用户 xxx 已经有超过 'max_user_connections' 个活动连接

感觉像是内存/缓存问题,但我不确定解决方法是什么。

我已尝试减少此 WordPress 实例的内存限额以及停用插件并删除其他 WordPress 安装(尽管由于上述 phpMyAdmin 问题我无法删除数据库字段)。

有什么想法吗?

【问题讨论】:

    标签: php mysql database wordpress caching


    【解决方案1】:

    这不是内存问题,而是 MySQL 的连接问题。

    MySQL 手册在这里介绍了它:

    http://dev.mysql.com/doc/refman/5.5/en/too-many-connections.html

    基本上,您的并发连接数是有限的,并且超出了该限制。它是间歇性的原因是,当 PHP 完成页面渲染时,它会断开连接,并且可供下一个人使用。

    如果您不在共享主机上,答案是打开您的 my.cnf 文件,调整该值,然后重新启动 MySQL。如果您在共享主机上,您将不得不与他们的支持系统交谈,看看他们是否会/可以提高它。

    HTH,

    =C=

    【讨论】:

      【解决方案2】:

      我的问题已经解决了。

      经调查,当数据库用户超过每个用户允许的最大连接数10时,网站正在加载数据库连接错误。

      在我们的共享平台中,它们允许最多 10 个并发连接到数据库,这在共享平台中是理想的,但遗憾的是,无法增加此限制。

      所以,我升级了我的托管计划。现在一切正常。

      【讨论】:

        猜你喜欢
        • 2016-03-25
        • 2011-05-17
        • 2021-05-28
        • 1970-01-01
        • 2015-08-11
        • 2012-12-29
        • 1970-01-01
        • 1970-01-01
        相关资源
        最近更新 更多