【问题标题】:Redis failed to connect: connection refused from NginxRedis 连接失败:来自 Nginx 的连接被拒绝
【发布时间】:2020-03-11 09:50:52
【问题描述】:

我在这个问题上苦苦挣扎了一个多星期,但仍然无法解决。

我正在尝试使用 Ansible 配置我们的环境,并且我想配置一个与生产环境相同的登台服务器,我已经设置了 Redis 服务器,它正在运行监听 6379 我已经启动并运行了 Nginx 并且它正在处理请求,但是当它到达 Lua 的一部分来连接到 Redis 时,它会抛出连接被拒绝的错误。

这里是 Nginx 调试日志:Link

Redis 在 6379 上监听

$ sudo lsof -i -P -n | grep LISTEN | grep 6379
redis-ser  1978         redis    4u  IPv6 138447828      0t0  TCP *:6379 (LISTEN)
redis-ser  1978         redis    5u  IPv4 138447829      0t0  TCP *:6379 (LISTEN)

通过 Python 连接 Redis

Python 2.7.12 (default, Oct  8 2019, 14:14:10) 
[GCC 5.4.0 20160609] on linux2
Type "help", "copyright", "credits" or "license" for more information.
import redis
redis.Redis(host='127.0.0.1', port=6379, db='0')
r.set("Test", 'value')
True
r.get("Test")
'value'

Lua 代码:

local red = redis:new()
red:set_timeout(500)
local ok, err = red:connect("127.0.0.1", 6379)
if not ok then
     ngx.say("Redis failed to connect: ", err)
     return
end

Nginx 配置:

server {
    listen 8080;
    server_name xxx.com;
    access_log /var/log/nginx/xxxx_access.log;
    error_log /var/log/nginx/xxxx_error.log debug;

    proxy_redirect     off;
    proxy_set_header Host   $host;
    proxy_set_header REMOTE_ADDR $http_cf_connecting_ip;
    proxy_set_header X-Real-IP  $http_cf_connecting_ip;
    proxy_set_header X-URI  $uri;
    proxy_set_header X-Scheme $scheme;
    proxy_set_header X-Forwarded-Protocol $scheme;

    location / {
        rewrite_by_lua_file '/var/www/xxxx/nginx/add_header_web.lua';
        proxy_pass http://xxxxx/;
    }
}

环境

Redis 3.2.0
Nginx: openresty/1.7.7.2
configure arguments: --prefix=/usr/local/openresty/nginx --with-debug --with-cc-opt='-I/opt/ngx_openresty-1.7.7.2/build/luajit-root/usr/local/openresty/luajit/include/luajit-2.1 -DNGX_LUA_USE_ASSERT -DNGX_LUA_ABORT_AT_PANIC -O2 -O2' --add-module=../ngx_devel_kit-0.2.19 --add-module=../echo-nginx-module-0.57 --add-module=../xss-nginx-module-0.04 --add-module=../ngx_coolkit-0.2rc2 --add-module=../set-misc-nginx-module-0.28 --add-module=../form-input-nginx-module-0.10 --add-module=../encrypted-session-nginx-module-0.03 --add-module=../srcache-nginx-module-0.28 --add-module=../ngx_lua-0.9.14 --add-module=../ngx_lua_upstream-0.02 --add-module=../headers-more-nginx-module-0.25 --add-module=../array-var-nginx-module-0.03 --add-module=../memc-nginx-module-0.15 --add-module=../redis2-nginx-module-0.11 --add-module=../redis-nginx-module-0.3.7 --add-module=../rds-json-nginx-module-0.13 --add-module=../rds-csv-nginx-module-0.05 --with-ld-opt='-Wl,-rpath,/usr/local/openresty/luajit/lib -L/opt/ngx_openresty-1.7.7.2/build/luajit-root/usr/local/openresty/luajit/lib -Wl,-rpath,/usr/local/lib' --conf-path=/etc/nginx/nginx.conf --with-http_realip_module --with-http_stub_status_module --with-http_geoip_module --with-http_ssl_module --with-http_sub_module --add-module=/opt/nginxmodules/nginx-upload-progress-module --add-module=/opt/nginxmodules/nginx-push-stream-module

更新:

好吧,我刚刚将我的 openresty 更新到最新版本,一切又恢复了工作

【问题讨论】:

  • 改变你的错误处理:而不是输出给用户的ngx.say,只需调用error 1)然后在那里终止请求,2)在error.log中记录错误文件。或者只是将您对red:connect 的电话转入assert()
  • 详细地说,我在数十个 OpenResty 项目中使用 Redis 并且它可以工作。能否提供一个完整的环境来重现问题?

标签: nginx redis lua openresty


【解决方案1】:

我遇到了同样的问题,但在来自谷歌群组的Chinese thread 的帮助下解决了这个问题。本质上,我们必须在连接时添加带有池名称的选项表。我不知道为什么,但它对我有用。

这是我的代码:

local options_table = {}
options_table["pool"] = "docker_server"
local ok, err = red:connect("10.211.55.8", 6379, options_table)

【讨论】:

    猜你喜欢
    • 2014-09-13
    • 2016-02-01
    • 2014-02-26
    • 2012-11-21
    • 2019-08-22
    • 2021-01-24
    • 2021-06-22
    • 1970-01-01
    • 1970-01-01
    相关资源
    最近更新 更多