【问题标题】:Corda node fail to start when connected to Oracle databaseCorda 节点连接到 Oracle 数据库时无法启动
【发布时间】:2021-05-25 12:39:38
【问题描述】:

我正在使用

  • Corda 企业版:4.5
  • 令牌-sdk:1.0
  • Oracle 驱动程序:ojdbc7.jar

出现以下错误

节点启动期间出现异常:检测到不兼容的架构更改。 请使用 database.initialiseSchema=true 运行节点。原因: 模式验证:列中遇到错误的列类型 表 [schem.fungible_token] 中的 [token_class];找到 [nvarchar (Types#NVARCHAR)],但期待 [varchar(255) (Types#VARCHAR)]

我们尝试了https://github.com/corda/token-sdk/issues/150 的解决方案 2,但是 database-manager-tool 没有加载 fungible-token-schema-v2.changelog-master.xml 文件。我们还尝试将 Token SDK 升级到 1.1,但 Corda 节点无法启动。请建议。谢谢

【问题讨论】:

  • Oracle 驱动程序版本看起来很糟糕。此外,Corda 不是补丁版本。如果您不能使用 4.7,请尝试 4.5.2 - 与支持人员核实最新版本。

标签: corda


【解决方案1】:

正如@wawrzek 所建议的,这看起来像是驱动程序问题。可能是架构迁移效果不佳。

仅根据这条消息,还不是很清楚。

最后一点是,如果您有 corda 企业,那么我建议您联系支持,因为他们应该能够帮助您解决这些特定问题。

【讨论】:

    猜你喜欢
    • 2021-08-27
    • 2018-10-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    相关资源
    最近更新 更多