【发布时间】:2011-01-11 03:50:57
【问题描述】:
我想添加另一个端口到 sql server 的默认 1433 端口。所以我打开了配置管理器,选择了Protocols for MSSQLSERVER,然后双击TCP/IP查看它的属性。然后我选择了IP Addresses 选项卡并向下滚动到IPAll 部分。然后我将 1433 更改为 1433,1450,这样我也可以使用 1450 端口连接到服务器。问题是此更改需要重新启动 sql server 服务,并且由于以下错误而停止它后我无法启动服务器:
The request failed or the service did not respond in a timely fashion. Consult the event log or other applicable error logs for details.
我在事件日志中看到以下错误:
SQL Server could not spawn FRunCM thread.
如果我从 tcp 端口中删除 1450,sql server 将能够再次运行而没有任何问题。
我以前做过,但我不明白为什么我不能在这个服务器上做。
【问题讨论】:
-
第二个端口设置为5000是否也有同样的问题?
-
不,它又没用了。我认为这可能是在阻止端口的服务器上运行的防病毒软件。我必须检查一下。
标签: sql-server tcp port