【问题标题】:I cannot change sql server's default port (1433)我无法更改 sql server 的默认端口 (1433)
【发布时间】:2011-01-11 03:50:57
【问题描述】:

我想添加另一个端口到 sql server 的默认 1433 端口。所以我打开了配置管理器,选择了Protocols for MSSQLSERVER,然后双击TCP/IP查看它的属性。然后我选择了IP Addresses 选项卡并向下滚动到IPAll 部分。然后我将 1433 更改为 1433,1450,这样我也可以使用 1450 端口连接到服务器。问题是此更改需要重新启动 sql server 服务,并且由于以下错误而停止它后我无法启动服务器:

The request failed or the service did not respond in a timely fashion. Consult the event log or other applicable error logs for details.

我在事件日志中看到以下错误:

SQL Server could not spawn FRunCM thread.

如果我从 tcp 端口中删除 1450,sql server 将能够再次运行而没有任何问题。

我以前做过,但我不明白为什么我不能在这个服务器上做。

【问题讨论】:

  • 第二个端口设置为5000是否也有同样的问题?
  • 不,它又没用了。我认为这可能是在阻止端口的服务器上运行的防病毒软件。我必须检查一下。

标签: sql-server tcp port


【解决方案1】:

您需要先在服务器中添加一个新的 TDS 端点,参见How to: Configure the Database Engine to Listen on Multiple TCP Ports

CREATE ENDPOINT [CustomConnection]
STATE = STARTED
AS TCP
   (LISTENER_PORT = 1450, LISTENER_IP =ALL)
FOR TSQL() ;
GO

然后将引擎配置为侦听两个端口,就像您正在做的那样。确保您选择了一个空闲端口,并确保该端口在防火墙中是允许的。

添加多个侦听端口的通常原因是将客户端关联到 NUMA 或软 NUMA,请参阅 How to: Map TCP/IP Ports to NUMA NodesHow to: Configure SQL Server to Use Soft-NUMA

【讨论】:

  • 似乎不适用于 sql server community (2017)
猜你喜欢
  • 1970-01-01
  • 1970-01-01
  • 2017-08-20
  • 2014-02-08
  • 2010-09-14
  • 1970-01-01
  • 1970-01-01
  • 1970-01-01
  • 1970-01-01
相关资源
最近更新 更多