【问题标题】:Incoming ZeroMQ traffic dropped by server due to NAT?由于 NAT,服务器丢弃了传入的 ZeroMQ 流量?
【发布时间】:2014-06-20 15:27:03
【问题描述】:

我有一个 ZMQ 服务器在端口 12345 TCP 上侦听。当另一台服务器在本地或通过 VM 连接到该端口时,它工作正常,但如果我从必须通过 Fios 防火墙上的端口转发的远程服务器尝试,它只会爆炸。数据包出现在 Wireshark 中,但 ZMQ 只是忽略它们。有没有办法克服这个问题?

【问题讨论】:

  • “ZMQ 只是忽略它们”是什么意思 - 日志是怎么说的?
  • 它没有在日志中显示任何内容。就像什么都没有到达zmq。数据包可以很好地到达服务器,但它好像并没有真正在听。

标签: python zeromq


【解决方案1】:

您不能多次绑定到同一个端口号,无论是来自同一个进程还是另一个。

当您使用已在使用的端口号发出绑定时,ZMQ 应该会失败。你在检查返回码吗?

【讨论】:

  • 问题不是ZMQ绑定不同的端口,问题是远程连接没有到达ZMQ。
  • OP 正在寻找流量未到达的原因。鉴于您应该只能在给定端口上绑定一次,提到的附加“服务器”似乎表明对事情如何工作的误解。
  • 即使那是真的,从这个陈述“当另一个服务器在本地或通过VM连接到该端口时它工作正常”;这不是问题。无论哪种方式,您的答案都应该是评论。
  • OSX 中似乎存在监听外部连接的问题。我在 Ubuntu 上重做了它,它运行良好,所以它显然是 OSX。就像有防火墙阻止它,但wireshark显示数据包进来,所以不可能那样。也许是 OSX 10.9 的错误?
猜你喜欢
  • 2023-03-30
  • 2011-11-08
  • 1970-01-01
  • 1970-01-01
  • 1970-01-01
  • 2015-12-02
  • 1970-01-01
  • 1970-01-01
  • 2016-09-21
相关资源
最近更新 更多