【问题标题】:Failed to run Zeppelin notebook demo Spark Streaming - Hortonworks sandbox无法运行 Zeppelin 笔记本演示 Spark Streaming - Hortonworks 沙箱
【发布时间】:2016-10-05 21:12:04
【问题描述】:

我尝试在 Hortonworks 沙盒 2.4(名为 twitter 的笔记本)中运行 Zeppelin 上可用的笔记本演示来学习 SparkStreaming。按照notebook顶部的提示(/* BEFORE START....),我登录Ambari修改Yarn服务的配置。

  • CPU => 容器:最小容器大小 (VCores) 4;最大容器大小(Vcores):8

  • 内存

  • 节点:2250MB

  • 容器:最小容器大小:768MB;最大容器大小:2250MB

修改后所有服务都重新启动,但是当我回到 Zeppelin 运行笔记本时,第二段 (/* UPDATE YOUR TWITTER CREDENTIALS */....) 始终处于“正在运行”但从未“完成”状态”。所有 Twitter 凭据均已更新。

P/S:不修改 YARN 配置,我可以运行第二段,但是运行第三段时,它总是“运行”但从未“完成”

感谢您的任何建议

【问题讨论】:

    标签: scala apache-spark-sql spark-streaming apache-zeppelin


    【解决方案1】:

    如果错误是 Error:YarnApplicationState: ACCEPTED: waiting for AM container to be allocated, launched and register

    将yarn.nodemanager.disk-health-checker.max-disk-utilization-per-disk-percentage 的值更改为99,将yarn maximum-am-resource-percent 的值更改为100

    【讨论】:

      猜你喜欢
      • 1970-01-01
      • 2019-07-02
      • 2017-01-29
      • 1970-01-01
      • 1970-01-01
      • 2020-07-17
      • 1970-01-01
      • 2020-11-18
      • 1970-01-01
      相关资源
      最近更新 更多