【问题标题】:Datastax OpsCenter 5.2.0 fails to backup to Amazon S3Datastax OpsCenter 5.2.0 无法备份到 Amazon S3
【发布时间】:2015-10-23 02:35:28
【问题描述】:

当我使用 Opscenter 创建 Amazon S3 备份作业时,它会失败并在日志和浏览器中显示以下消息。它在创建步骤中失败了。我尝试了所有键空间和单个键空间...DSE 版本 4.7.1 .. Opscenter 版本 5.2.0。我刚刚创建了这个集群......并且是第一次创建备份作业。

请指教。

2015-07-31 11:41:35+0000 [] 错误:调用装饰器时出现问题 (LibcloudError):'此存储桶位于不同的区域。请使用正确的驱动程序。'> _inlineCallbacks 中的文件“/usr/share/opscenter/lib/py-redhat/2.6/shared/amd64/twisted/internet/defer.py”,第 1018 行 结果 = result.throwExceptionIntoGenerator(g)

      File "/usr/share/opscenter/lib/py-redhat/2.6/shared/amd64/twisted/python/failure.py", line 349, in throwExceptionIntoGenerator
        return g.throw(self.type, self.value, self.tb)

      File "/usr/lib/python2.6/site-packages/opscenterd/WebServer.py", line 2119, in DestinationsValidateController

      File "/usr/share/opscenter/lib/py-redhat/2.6/shared/amd64/twisted/internet/defer.py", line 1018, in _inlineCallbacks
        result = result.throwExceptionIntoGenerator(g)

      File "/usr/share/opscenter/lib/py-redhat/2.6/shared/amd64/twisted/python/failure.py", line 349, in throwExceptionIntoGenerator
        return g.throw(self.type, self.value, self.tb)

      File "/usr/lib/python2.6/site-packages/opscenterd/backups/Destinations.py", line 488, in validate

      File "/usr/share/opscenter/lib/py-redhat/2.6/shared/amd64/twisted/internet/defer.py", line 1018, in _inlineCallbacks
        result = result.throwExceptionIntoGenerator(g)

      File "/usr/share/opscenter/lib/py-redhat/2.6/shared/amd64/twisted/python/failure.py", line 349, in throwExceptionIntoGenerator
        return g.throw(self.type, self.value, self.tb)

      File "/usr/lib/python2.6/site-packages/opscenterd/backups/Destinations.py", line 422, in validate

      File "/usr/share/opscenter/lib/py-redhat/2.6/shared/amd64/twisted/internet/defer.py", line 1018, in _inlineCallbacks
        result = result.throwExceptionIntoGenerator(g)

      File "/usr/share/opscenter/lib/py-redhat/2.6/shared/amd64/twisted/python/failure.py", line 349, in throwExceptionIntoGenerator
        return g.throw(self.type, self.value, self.tb)

      File "/usr/lib/python2.6/site-packages/opscenterd/backups/Destinations.py", line 408, in validate_connection

      File "/usr/share/opscenter/lib/py-redhat/2.6/shared/amd64/twisted/python/threadpool.py", line 207, in _worker
        result = context.call(ctx, function, *args, **kwargs)

      File "/usr/share/opscenter/lib/py-redhat/2.6/shared/amd64/twisted/python/context.py", line 59, in callWithContext
        return self.currentContext().callWithContext(ctx, func, *args, **kw)

      File "/usr/share/opscenter/lib/py-redhat/2.6/shared/amd64/twisted/python/context.py", line 37, in callWithContext
        return func(*args,**kw)

      File "/usr/lib/python2.6/site-packages/opscenterd/backups/Destinations.py", line 400, in run_validate_connection

      File "/usr/share/opscenter/lib/py/libcloud/storage/drivers/s3.py", line 304, in get_container
        method='HEAD')

      File "/usr/share/opscenter/lib/py/libcloud/common/base.py", line 736, in request
        response = responseCls(**kwargs)

      File "/usr/share/opscenter/lib/py/libcloud/common/base.py", line 117, in __init__
        raise Exception(self.parse_error())

      File "/usr/share/opscenter/lib/py/libcloud/storage/drivers/s3.py", line 85, in parse_error
        driver=S3StorageDriver)

【问题讨论】:

    标签: amazon-s3 cassandra datastax datastax-enterprise opscenter


    【解决方案1】:

    转到您的 cluter_name.conf 文件。在代理标题下(我想在您的情况下它是空白的),并添加以下行:

    remote_backup_region = <region S3 bucket is in>
    

    区域的适当值是:

    us-standard 
    us-west-1 
    us-west-2 
    eu-west-1
    eu-central-1 
    ap-northeast-1 
    ap-southeast-1
    ap-southeast-2
    sa-east-1
    

    保存该设置后,重新启动 OpsCenter 并再次尝试备份。

    【讨论】:

    • 另外我想指出这是一个临时修复。一旦有了更持久的解决方案,我就可以更新。
    • 对于使用 linux 安装程序安装的 DSE,在我的情况下,该文件位于 /usr/share/opscenter/conf/clusters/local.conf。
    • 我的存储桶在 us-east-1。我在代理节中使用了remote_backup_region = us-standard。在 Opscenter 中设置远程位置时验证失败。 Location validation error: Call to /local/backups/destination_validate timed out.
    • 嗨 @PhilB 和 LHWizard 我已在存储桶 A 上安排了集群 A 的备份。我正在尝试创建集群 B 并直接将存储桶 A 中的数据恢复到其中以节省时间和精力。当我尝试从备份中恢复时,我得到了类似于 LHWizard 的东西。我在这里缺少什么吗?位置验证错误:调用 /Development_Cluster/backups/destination_validate 超时。
    • @HarshaSharma 更新或将“[ui] default_api_timeout = 30”添加到您的 opscenterd.conf 文件,然后重新启动 OpsCenter。这将增加与 AWS 超时的 API 的超时时间。
    猜你喜欢
    • 2015-12-14
    • 1970-01-01
    • 2016-09-07
    • 2015-06-04
    • 2016-12-02
    • 2015-05-21
    • 2016-05-19
    • 2017-03-03
    • 1970-01-01
    相关资源
    最近更新 更多