【问题标题】:Datastax connection exception when using beeline or hive2 jdbc driver (Tableau)使用 beeline 或 hive2 jdbc 驱动程序时出现 Datastax 连接异常 (Tableau)
【发布时间】:2016-08-12 04:05:45
【问题描述】:

我已经在我的开发虚拟机(Centos 7)上安装了Datastax enterprise 2.8。安装顺利进行,单节点集群运行良好。但是当我尝试使用 beeline 或 hive2 jdbc 驱动程序连接到集群时,出现如下所示的错误。我的主要目标是使用 Datastax Enterprise 驱动程序或 Spark Sql 驱动程序连接 Tableau。

观察到的错误是:

错误 2016-04-14 17:57:56,915 org.apache.thrift.server.TThreadPoolServer:期间发生错误 消息的处理。 java.lang.RuntimeException: org.apache.thrift.transport.TTransportException:无效状态-128 在 org.apache.thrift.transport.TSaslServerTransport$Factory.getTransport(TSaslServerTransport.java:219) ~[libthrift-0.9.3.jar:0.9.3] 在 org.apache.thrift.server.TThreadPoolServer$WorkerProcess.run(TThreadPoolServer.java:269) ~[libthrift-0.9.3.jar:0.9.3] 在 java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [na:1.7.0_99] 在 java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [na:1.7.0_99] 在 java.lang.Thread.run(Thread.java:745) [na:1.7.0_99] 引起:org.apache.thrift.transport.TTransportException: 无效状态 -128 在 org.apache.thrift.transport.TSaslTransport.sendAndThrowMessage(TSaslTransport.java:232) ~[libthrift-0.9.3.jar:0.9.3] 在 org.apache.thrift.transport.TSaslTransport.receiveSaslMessage(TSaslTransport.java:184) ~[libthrift-0.9.3.jar:0.9.3] 在 org.apache.thrift.transport.TSaslServerTransport.handleSaslStartMessage(TSaslServerTransport.java:125) ~[libthrift-0.9.3.jar:0.9.3] 在 org.apache.thrift.transport.TSaslTransport.open(TSaslTransport.java:271) ~[libthrift-0.9.3.jar:0.9.3] 在 org.apache.thrift.transport.TSaslServerTransport.open(TSaslServerTransport.java:41) ~[libthrift-0.9.3.jar:0.9.3] 在 org.apache.thrift.transport.TSaslServerTransport$Factory.getTransport(TSaslServerTransport.java:216) ~[libthrift-0.9.3.jar:0.9.3] ...省略了 4 个常见框架错误 2016-04-14 17:58:59,140 org.apache.spark.scheduler.cluster.SparkDeploySchedulerBackend: 应用程序已被杀死。原因:师父删除了我们的申请: 杀了

我的 cassandra.yml 配置:

cluster_name:'Cluster1'

num_tokens: 256

hinted_handoff_enabled: 真hinted_handoff_throttle_in_kb: 1024 max_hints_delivery_threads: 2

batchlog_replay_throttle_in_kb:1024

身份验证器:AllowAllAuthenticator

授权人:AllowAllAuthorizer

permissions_validity_in_ms: 2000

分区器:org.apache.cassandra.dht.Murmur3Partitioner

数据文件目录: - /var/lib/cassandra/data

commitlog_directory: /var/lib/cassandra/commitlog

disk_failure_policy:停止

commit_failure_policy:停止

key_cache_size_in_mb:

key_cache_save_period: 14400

row_cache_size_in_mb: 0

row_cache_save_period: 0

counter_cache_size_in_mb:

counter_cache_save_period:7200

saved_caches_directory: /var/lib/cassandra/saved_caches

commitlog_sync:定期 commitlog_sync_period_in_ms:10000

commitlog_segment_size_in_mb: 32

种子提供者: - 类名:org.apache.cassandra.locator.SimpleSeedProvider 参数: - 种子:“10.33.1.124”

concurrent_reads: 32 concurrent_writes: 32 concurrent_counter_writes: 32

memtable_allocation_type: heap_buffers

index_summary_capacity_in_mb:

index_summary_resize_interval_in_minutes:60

trickle_fsync: 错误滴流_fsync_interval_in_kb: 10240

存储端口:7000

ssl_storage_port: 7001

监听地址:10.33.1.124

start_native_transport: 真 native_transport_port: 9042

start_rpc: 真

rpc_address:10.33.1.124

rpc_port: 9160

rpc_keepalive: 真

rpc_server_type: 同步

thrift_framed_transport_size_in_mb:15

增量备份:假

snapshot_before_compaction: false

自动快照:真

tombstone_warn_threshold:1000 tombstone_failure_threshold:100000

column_index_size_in_kb:64

batch_size_warn_threshold_in_kb:64

compaction_throughput_mb_per_sec: 16

compaction_large_partition_warning_threshold_mb:100

sstable_preemptive_open_interval_in_mb:50

read_request_timeout_in_ms: 5000 range_request_timeout_in_ms: 10000 write_request_timeout_in_ms:2000 counter_write_request_timeout_in_ms: 5000 cas_contention_timeout_in_ms:1000 truncate_request_timeout_in_ms: 60000 request_timeout_in_ms: 10000

cross_node_timeout: false

endpoint_snitch: com.datastax.bdp.snitch.DseSimpleSnitch

dynamic_snitch_update_interval_in_ms:100 dynamic_snitch_reset_interval_in_ms:600000 dynamic_snitch_badness_threshold: 0.1

request_scheduler: org.apache.cassandra.scheduler.NoScheduler

server_encryption_options: internode_encryption:无 密钥库:资源/dse/conf/.keystore keystore_password:卡桑德拉 信任库:资源/dse/conf/.truststore truststore_password: cassandra

client_encryption_options: 启用:假 可选:假 密钥库:资源/dse/conf/.keystore keystore_password: cassandra

internode_compression: 直流

inter_dc_tcp_nodelay: 假

concurrent_counter_writes: 32

counter_cache_size_in_mb:

counter_cache_save_period:7200

memtable_allocation_type: heap_buffers

index_summary_capacity_in_mb:

index_summary_resize_interval_in_minutes:60

sstable_preemptive_open_interval_in_mb:50

counter_write_request_timeout_in_ms:5000

使用直线连接时出现错误:

dse beeline Beeline 版本 0.12.0.11 by Apache Hive beeline> !connect jdbc:hive2://10.33.1.124:10000 扫描在 10 毫秒内完成 jdbc:hive2://10.33.1.124:10000 输入用户名 jdbc:hive2://10.33.1.124:10000: cassandra 输入密码 jdbc:hive2://10.33.1.124:10000: ********* 错误:无效的 URL: jdbc:hive2://10.33.1.124:10000 (state=08S01,code=0) 0: jdbc:hive2://10.33.1.124:10000> !connect jdbc:hive2://10.33.1.124:10000 连接到 jdbc:hive2://10.33.1.124:10000 输入用户名 jdbc:hive2://10.33.1.124:10000:输入密码 jdbc:hive2://10.33.1.124:10000:错误:无效的 URL: jdbc:hive2://10.33.1.124:10000 (state=08S01,code=0) 1: jdbc:hive2://10.33.1.124:10000>

我在通过Tableau 连接时也看到了类似的错误。

【问题讨论】:

    标签: tableau-api datastax datastax-enterprise spark-cassandra-connector


    【解决方案1】:

    JDBC 驱动程序连接到 SparkSql Thrift 服务器。不启动就无法连接。

    dse spark-sql-thriftserver
    /Users/russellspitzer/dse/bin/dse:
    usage: dse spark-sql-thriftserver <command> [Spark SQL Thriftserver Options]
    
    Available commands:
      start                             Start Spark SQL Thriftserver
      stop                              Stops Spark SQL Thriftserver
    

    【讨论】:

      猜你喜欢
      • 1970-01-01
      • 2023-04-06
      • 2013-12-22
      • 2014-11-11
      • 2017-12-23
      • 2019-07-18
      • 2014-06-30
      • 2014-11-07
      • 1970-01-01
      相关资源
      最近更新 更多