【发布时间】:2018-12-02 03:21:24
【问题描述】:
我在我的计算机 (mac os High Sierra 10.13.4) 上为 Rails 应用程序工作。我通过 Homebrew 安装了 Postgres、Redis 和 ElasticSearch。 我最近开始在一个新分支上 dockerize 应用程序。
当我回到我的主分支时,所有的 brew 服务都没有工作:
PG::ConnectionBad - could not connect to server: Connection refused
感谢https://dba.stackexchange.com/questions/75214/postgresql-not-running-on-mac ,我解决了这个问题
无法连接到 redis
我通过运行redis-cli 解决了这个问题
Errno::ECONNREFUSED - Failed to open TCP connection to localhost:9200 (Connection refused - connect(2) for "::1" port 9200)
我尝试停止/启动、卸载/重新安装 elasticsearch,甚至卸载/重新安装 Homebrew。我正在考虑重新安装我的电脑。
我不明白在 docker 上工作如何会破坏我计算机上的服务,我认为它应该可以解决这类问题。
非常感谢任何有关使 elasticsearch 工作的帮助!
【问题讨论】:
-
这可能是因为这些服务都不会在启动时启动。如果您从未将它们设置为开机启动,则需要手动启动它们。
-
我尝试 brew services stop/start postgresql elasticsearch 和 redis 但它没有解决我的问题。
-
您查看过每个日志文件吗?
-
请使用 [homebrew] 标签而不是 [brew],这与此无关。我编辑了您的问题以修复标签。谢谢!
标签: docker elasticsearch homebrew