【问题标题】:Logstash Failing to Connect to Elasticsearch ClusterLogstash 无法连接到 Elasticsearch 集群
【发布时间】:2015-10-27 23:43:26
【问题描述】:

当我的 elasticsearch.yml 文件为:

cluster.name: elasticsearch-sam-dev
node.name: Wolverine

我的logstash输出配置为:

output {
    elasticsearch {
    cluster => "elasticsearch-sam-dev"
    host => localhost
 }
   stdout { codec => rubydebug }
}

它无法连接到集群,无法找出原因。当我注释掉 logstash 配置和 elasticsearch.yml 文件中的行集群时,它可以工作。

我得到的错误:

Logstash 错误 - 未完全复制,因为无法从开发环境复制和粘贴 :(

org.elasticsearch.discovery.zend.ping.unicast.UnicastZenPing$4 handlException
WARNING: [logstash-mymachine] failed to send ping to [[

Logstash 转发器错误:

Connecting to [127.0.0.1]:5000 (127.0.0.1)
Failed to tls handshake with 127.0.0.1 read tcp 127.0.0.1:5000: i/o timeout

现在,当我在没有集群名称的情况下重新启动 logstash、logstash-forwarder、elasticsearch 时,一切都会神奇地工作,logstash-forwarder 会处理“x”个事件,并且 logstash 会检测到节点 Wolverine。我无法弄清楚为什么集群名称会导致问题。有其他人遇到过同样的问题并设法解决了吗?

谢谢

【问题讨论】:

    标签: logstash elasticsearch logstash-forwarder


    【解决方案1】:

    我解决了这个问题,在我的 logstash 输出配置中我需要提供一个端口号,所以我的最终配置如下所示,不知道为什么我需要提供一个端口,因为假设它将采用默认值 9300 ,但它确实有效。

    output {
      elasticsearch {
      cluster => "elasticsearch-sam-dev"
      host => localhost
      port => "9300"
     }
       stdout { codec => rubydebug }
    }
    

    【讨论】:

      猜你喜欢
      • 2021-08-26
      • 2020-07-12
      • 2022-10-20
      • 2021-09-23
      • 1970-01-01
      • 2021-11-23
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      相关资源
      最近更新 更多