【发布时间】:2019-07-27 00:36:16
【问题描述】:
我正在尝试在服务器上设置 filebeat,然后在 Elastic Stack Docker 容器设置上运行设置。但目前无论我尝试什么,都没有办法让它工作。无论有没有 https,我都会收到以下错误:
2019-03-05T14:58:20.458+0100 ERROR instance/beat.go:911 Exiting: Failed to import index-pattern: Failed to load directory /usr/share/filebeat/kibana/6/index-pattern:
error loading /usr/share/filebeat/kibana/6/index-pattern/filebeat.json: fail to execute the HTTP POST request: Post http://10.248.115.125:5601/api/kibana/dashboards/import?force=true: net/http: request canceled (Client.Timeout exceeded while awaiting headers). Response:
Exiting: Failed to import index-pattern: Failed to load directory /usr/share/filebeat/kibana/6/index-pattern:
error loading /usr/share/filebeat/kibana/6/index-pattern/filebeat.json: fail to execute the HTTP POST request: Post http://10.248.115.125:5601/api/kibana/dashboards/import?force=true: net/http: request canceled (Client.Timeout exceeded while awaiting headers). Response:
firebeat.yml 配置为:
# List of inputs to fetch data.
filebeat.inputs:
- type: log
paths:
- "/var/log/nova/*.log"
document_type: nova
paths:
- "/var/log/neutron/*.log"
document_type: neutron
paths:
- "/var/log/messages"
document_type: syslog
paths:
- "/var/log/openvswitch/*.log"
document_type: openvswitch
paths:
- "/var/log/ceilometer/*.log"
document_type: ceilometer
paths:
- "/var/log/libvirt/*.log"
document_type: libvirt
# Change to true to enable this input configuration.
enabled: true
output.elasticsearch:
hosts: '10.000.000.000:9200'
# Optional SSL settings
#ssl.enabled: true
#ssl.verification_mode: "none"
protocol: "http"
#username: "elastic"
#password: "Nd6nFv8ktCbZMqKgiLsFgQ=="
#template.name: "filebeat"
#template.path: "filebeat.template.json"
setup.kibana:
host: "http://10.000.000.000:5601"
#username: "elastic"
#password: "Nd6nFv8ktCbZMqKgiLsFgQ=="
protocol: "http"
ssl.enabled: false
processors:
- add_host_metadata: ~
- add_cloud_metadata: ~
filebeat.config.modules:
# Glob pattern for configuration loading
path: ${path.config}/modules.d/*.yml
# Set to true to enable config reloading
reload.enabled: false
# Period on which files under path should be checked for changes
#reload.period: 10s
Kibana 在 Docker 容器中的其他主机上运行 Elasticsearch 和 logstash。
【问题讨论】:
标签: docker elasticsearch kibana elastic-stack filebeat