【发布时间】:2016-03-01 15:38:19
【问题描述】:
当我从公共 elasticsearch 存储库中提取图像时,使用该提取图像的生成容器对我来说工作正常,没有权限问题。
docker pull elasticsearch
docker run -d elasticsearch
但是当我使用 Dockerfile 生成一个容器时,该容器在公共仓库中可用,这给了我权限问题。我确实有与公共仓库相同的目录结构。
myfolder/Dockerfile
myfolder/docker-entrypoint.sh
myfolder/config/elasticsearch.yml
myfolder/config/logging.yml
https://github.com/docker-library/elasticsearch/tree/0d393d9a0a2e24fca022a89ad10c7050b2925292/2.1
命令:- 1) 使用 Dockerfile 构建镜像
sudo docker build -t testuser/testelastic:v1 .
2) 从构建的镜像中生成容器
sudo docker run -d --name elastic -v ./config:/config testuser/testelastic:v1
但每次我尝试从上述自定义构建映像中生成任何容器时都会出现以下错误。
Error response from daemon: Cannot start container 8e72f3c33d054f5883b2de9e7673bc032333e633e3f43905d7d22a12ea76ad04: [8] System error: exec: "/docker-entrypoint.sh": permission denied
【问题讨论】:
标签: elasticsearch docker containers