【问题标题】:Missing data when using unique count and creating an aggregation in Kibana在 Kibana 中使用唯一计数和创建聚合时缺少数据
【发布时间】:2016-02-11 02:44:15
【问题描述】:

我在 Kibana 中有一种行为,我无法解释。下面是一个简单的条形图,统计唯一用户,按应用程序和角色过滤,并确保日志中存在某些字段:

这张图显示我有大约。 170 个用户,角色为“Landmand”。如果我按术语“fields.Role”分割条形图,我希望得到一个相同的图表,因为我已经在搜索中应用了一个指定“fields.Role:Landmand”的过滤器。但是我看到了。

这突然将唯一计数限制为大约。 150 个用户。我尝试过使用不同的字段,它似乎具有相同的行为 - 一旦我拆分条形,我似乎以某种方式限制了数据。

非常感谢任何信息。

【问题讨论】:

    标签: elasticsearch kibana kibana-4


    【解决方案1】:

    这是因为它使用cardinality aggregation 来进行唯一计数。正如链接中所解释的,计数是近似的,并且有一个错误百分比。只需进行快速测试,尝试复制请求并尝试使用不同的精度阈值来查看差异。

    要设置自定义precision_threshold,您可以使用高级部分并将自定义 JSON 输入放入聚合:

    如果您转到 Request 部分,您实际上可以看到阈值已添加到基数聚合中。

    【讨论】:

    • 哇——我不知道。谢谢。在这种情况下,35% 的错误百分比相当大。
    • 旁注 - 你知道是否可以通过 json 输入字段在可视化中设置它吗?
    • @jaspernygaard 你问是否可以在 Kibana 中设置精度阈值?
    • 是的,可以通过 Kibana4 中的 json 输入字段直接在可视化中,也可以在 ES 中全局使用。
    猜你喜欢
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 2016-08-21
    • 1970-01-01
    • 2019-10-09
    • 2021-10-25
    • 2020-12-17
    相关资源
    最近更新 更多