【问题标题】:Can not connect to WebHDFS by port 14000 in Cloudera Manager无法通过 Cloudera Manager 中的端口 14000 连接到 WebHDFS
【发布时间】:2019-12-25 09:59:20
【问题描述】:

我有一个 Cloudera(版本为 cdh6.2.0)集群,每个组件(HDFS、HIVE 等)都运行良好。但是,最近想连接WebHDFS,在NameNode上执行命令netstat -antpl|grep 14000,发现port(14000)根本没有运行。

我已确认在 Cloudera Manager 中启用了 WebHDFS,并且默认使用14000 端口。

此外,我还尝试了50070 端口,它也没有监听。我也试过curl

curl -i "http://localhost:14000/webhdfs/v1/user/user.name=cloudera&op=GETFILESTATUS"
curl: (7) Failed to connect to localhost port 14000: Connection refused

感谢您的帮助。谢谢。

【问题讨论】:

    标签: hadoop hdfs cloudera webhdfs


    【解决方案1】:

    我改用9870 端口解决了这个问题。

    我发现我的 Hadoop 版本是 3.0,它正在使用 9870 而不是 50070 监听 dfs.namenode.http-address

    14000 可以用于HTTPS REST。

    参考: https://community.cloudera.com/t5/Support-Questions/Cannot-connect-to-webhdfs/td-p/34830

    【讨论】:

    • hdfs getconf -confKey dfs.namenode.http-address
    猜你喜欢
    • 1970-01-01
    • 2018-04-06
    • 1970-01-01
    • 2011-12-03
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 2021-05-04
    • 1970-01-01
    相关资源
    最近更新 更多