【发布时间】:2019-12-25 09:59:20
【问题描述】:
我有一个 Cloudera(版本为 cdh6.2.0)集群,每个组件(HDFS、HIVE 等)都运行良好。但是,最近想连接WebHDFS,在NameNode上执行命令netstat -antpl|grep 14000,发现port(14000)根本没有运行。
我已确认在 Cloudera Manager 中启用了 WebHDFS,并且默认使用14000 端口。
此外,我还尝试了50070 端口,它也没有监听。我也试过curl:
curl -i "http://localhost:14000/webhdfs/v1/user/user.name=cloudera&op=GETFILESTATUS"
curl: (7) Failed to connect to localhost port 14000: Connection refused
感谢您的帮助。谢谢。
【问题讨论】:
标签: hadoop hdfs cloudera webhdfs