【问题标题】:"Error from server (NotFound): deployments.apps "wordpress" not found" I am getting this error although I've deployed it?“来自服务器的错误 (NotFound): deployments.apps "wordpress" not found" 虽然我已经部署了它,但我收到了这个错误?
【发布时间】:2023-03-13 11:05:01
【问题描述】:

我正在尝试将已创建的 pod 部署为服务,但我不断收到上述错误。

第一个错误是因为我前几天已经部署了 pod。但第二个错误是主要问题。

如果有人能帮助我,那就太好了。

【问题讨论】:

  • 您的 kubectl run 命令创建了 pod 并且您正在尝试公开部署。 Pod 和部署是不同的实体。

标签: kubernetes kubernetes-pod kubernetes-deployment


【解决方案1】:
kubectl run ...

用于在 pod 中创建和运行特定图像。 [reference]

kubectl expose ...

用于将资源(pod、service、replicationcontroller、deployment、replicaset)公开为新的 k8s 服务。 [reference]

您正在做的是使用kubectl run 创建一个pod,并使用kubectl expose deployment 公开一个部署。这是两种不同的资源。这就是您收到 NotFound 错误的原因 - 因为指定的 部署 不存在。

你可以做的要么是

kubectl expose pod ...

create a deployment

【讨论】:

    猜你喜欢
    • 1970-01-01
    • 1970-01-01
    • 2021-06-29
    • 2020-10-23
    • 2021-11-02
    • 1970-01-01
    • 1970-01-01
    • 2020-10-24
    • 2019-05-26
    相关资源
    最近更新 更多