【问题标题】:Openshift down after restore database of drupal 7恢复drupal 7的数据库后Openshift down
【发布时间】:2015-05-05 19:30:48
【问题描述】:

我在 openshift 上使用自己的快速启动 drupal 创建了 drupal 可扩展应用程序,然后通过将文件夹链接到 drupal 和 active 添加我的模块和主题, 我使用备份/迁移模块来恢复我的备份,但是在执行应用程序关闭 doe 第 7 层错误代码 500 后,我将档位限制设置为 1 但未修复。 我检查日志: [WARNING] 062/120200 (450117) : 服务器 express/local-gear is DOWN, 原因: Layer7 错误状态, code: 500, info: "HTTP s 状态检查返回代码 500",检查持续时间:516 毫秒。剩余 0 个活动服务器和 0 个备份服务器。0 个活动会话,0 重新排队,0 剩余在队列中。 php日志: [Wed Mar 04 10:46:21 2015] [notice] Apache/2.2.15 (Unix) 已配置 -- 恢复正常操作 (98)地址已在使用:make_sock:无法绑定到地址127.10.83.1:8080

我在运行我自己的 drupal 时给出了这个错误,但在恢复数据库之前快速启动工作正常!

【问题讨论】:

    标签: database drupal openshift


    【解决方案1】:

    尝试强制停止和启动,也有可能您在应用程序的某处硬编码了 IP 地址,并且需要更改它以使用环境变量,因为您的新设备具有不同的 IP 地址。

    【讨论】:

      【解决方案2】:

      这部分...

      “地址已在使用中:make_sock:无法绑定到地址 127.10.83.1:8080”

      ...建议您将开发版本推送到服务器。您可能会认为 IP 地址是一个公共地址,并且它会绑定到端口 80 而不是 8080。

      我的 server.js 有这样的代码...

              //  Set the environment variables we need.
          self.ipaddress = process.env.OPENSHIFT_NODEJS_IP;
          self.port      = process.env.OPENSHIFT_NODEJS_PORT || 8080;
      
          if (typeof self.ipaddress === "undefined") {
              //  Log errors on OpenShift but continue w/ 127.0.0.1 - this
              //  allows us to run/test the app locally.
              console.warn('No OPENSHIFT_NODEJS_IP var, using 127.0.0.1');
              self.ipaddress = "127.0.0.1";
          };
          ...
          self.app.listen(self.port, self.ipaddress, function() {
              console.log('%s: WebApp started on %s:%d ...',
                          Date(Date.now() ), self.ipaddress, self.port);
          });
      

      我不建议直接使用此代码,我只是表明应用应有条件地侦听本地(私有)IP 地址/端口组合或远程(公共)IP 地址/端口组合。您将使用该 process.env.OPENSHIFT_NODEJS_IP 环境变量的存在来了解您在 Node.Js 设置下的生产环境中运行。你自己的 Drupal 设备也会有类似的东西。

      【讨论】:

        猜你喜欢
        • 2019-12-16
        • 1970-01-01
        • 1970-01-01
        • 1970-01-01
        • 2021-04-17
        • 1970-01-01
        • 1970-01-01
        • 1970-01-01
        • 1970-01-01
        相关资源
        最近更新 更多