【发布时间】:2020-04-19 03:35:36
【问题描述】:
我在 AWS 上使用 kops 设置了一个 kubernetes 集群。
现在,服务器 url 是https://old-server-url.com。 该 url 在 Route53 上配置,指向集群主实例的公共 ip。
我想将其更改为 https://new-server-url.com。 我在 Route53 上配置了与主 IP 相同的新 url。但它只是打开带有新 URL 的 kubernetes 仪表板。 我无法使用此 url 通过 kubectl 访问 kubernetes 服务器。
这是我在使用新 url 更改 kubeconfig 文件并运行 kubectl get pods 命令时遇到的错误。
"Unable to connect to the server: x509: certificate is valid for internal.old-server-url.com, old-server-url.com, kubernetes, kubernetes.default, kubernetes.default.svc, kubernetes.default.svc.cluster.local, not new-server-url.com"
我要改什么配置,只改kubernetes集群的服务器,可以通过kube config/kubectl访问?
更新: 在 kubectl 命令中使用 --insecure-skip-tls-verify 标志后,我可以访问我的集群。但这是不安全的。我想知道如何在 kops 配置的集群中更改我的证书,而对这种情况的影响最小。
【问题讨论】:
标签: amazon-web-services amazon-ec2 kubernetes amazon-route53 kops